Admin Console Shows Stale Device Information or Doesn’t Show Recently Enrolled Devices

Admin Console Shows Stale Device Information or Doesn’t Show Recently Enrolled Devices

Issue

MobiControl admin console shows outdated device information and/or does not show recently enrolled devices for up to 24 hours when Management Service and Deployment Service are hosted independently from each other.

Affects

  • SOTI MobiControl v14.0.0 and higher when the Management Service and Deployment Service are hosted on different hosts.

Cause

Device information presented in the MobiControl v14 admin console is primarily retrieved from the “MobiControl Search” index stored on the Management Service. During device check-in and/or enrollment the Deployment Server initiates a notification to the Management Server to update its index with the new information. If this communication fails, the index will not be updated with the necessary information until the next device check-in or when the nightly “MobiControl Search Sync” occurs (by default every 24 hours).

Possible reasons for these communication failures include:

  • TCP 9200 is blocked between the Management Service and Deployment Service
  • Network interruption between the Deployment Service and Management Service
  • MobiControl Search Service is not running during device check-in or enrollment, or the host was offline completely.

Resolution

Ensure index integrity by:

  • Opening TCP 9200 between the Management Server and the Deployment Server
  • Starting the MobiControl Search Service before the Deployment Servers

If you believe device information is out of date and would like to immediately synchronize the index, execute “Sync” in the “Servers > Global Settings > MobiControl Search Sync” areas of the admin console.

  • 467 Views
  • 1 Favourite
Give us your feedback
Give us your feedback
Feedback