Device-based VPP Applications do not Update

Device-based VPP Applications do not Update

Issue

On some iOS devices, an iOS application deployed using device-based Volume Purchase Plan (VPP) licensing is not updated by MobiControl.

Affects

  • iOS version less than 10.3

Cause

A known iOS issue that prevents Mobile Device Management (MDM) solutions from updating iOS applications deployed using device-based VPP licensing.

Resolution

The update of device-based VPP applications is only officially supported on iOS 10.3 and greater.  If you have some devices that are on a lower version of iOS, you can either:

  • Update all devices to iOS 10.3+ so that you can benefit from the ability to update their Device-based VPP applications.
  • Accept that your devices running a version of iOS lower than 10.3 will have to uninstall and reinstall their Device-based VPP applications.
  • Convert your VPP licenses to user-based. This is discouraged and only to be used as a last resort.
  • 3867 Views
  • 0 Favourite

Give us your feedback
Give us your feedback
Feedback