15.1.3 Build 1021 -> 15.3.0 Build 6713 MCDeplSvr.exe not starting anymore

15.1.3 Build 1021 -> 15.3.0 Build 6713 MCDeplSvr.exe not starting anymore

Hello,

After the update we found this strange log:

2021-03-11 17:31:50,290 (0x00000908) [ERROR] [CMyService::ServiceMain] Error starting Deployment Server Extensions: Newtonsoft.Json.JsonReaderException: Input string '697CDE57CF56FBC5049CDE5FBC18E7CD168FCC48FB46F9955F96D319F358E98133A8E939C077CDB925AAAF71844AD8ED2DF5AF7D8E3A9FAB739AE52ED37AD3E646C99617F42982DB03E69E78A81BB5935CD3D71FB803A3945493DF64A52BB29B61E2AB6187319EA368E0A34F832B82B66BF2B127C4369DB274B3FF58852F95A1880A40D734902E648E1B44DF2A98475E8A04428A6CC62D1D9F0A51816BAA072F' is not a valid number. Path '', line 1, position 320.
at Newtonsoft.Json.JsonTextReader.ParseReadNumber(ReadType readType, Char firstChar, Int32 initialPosition)
at Newtonsoft.Json.JsonTextReader.ParseValue()
at Newtonsoft.Json.JsonReader.ReadForType(JsonContract contract, Boolean hasConverter)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
at Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
at Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
at Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings)
at Soti.MobiControl.Settings.SerializationHelper.GetDeserializeObject[T](String serializedValue)
at Soti.MobiControl.Settings.SettingsService.Decrypt(String encryptedSetting)
at Soti.MobiControl.Settings.SettingsService.GetSetting[T](String feature, String setting, CachingOptions cachingOptions, ObfuscationOption obfuscationOption, T defaultValue)
at Soti.MobiControl.CoreFeatures.Implementation.GlobalProxy.ProxySettingManagementService.GetProxySetting()
at Soti.MobiControl.CoreFeatures.Implementation.GlobalProxy.ProxyService.UpdateGlobalProxy()
at Soti.MobiControl.DeploymentServerExtensions.DeploymentServerExtensionsHost.Start()
at CMyService.ServiceMain(CMyService* , UInt32 dwArgc, Char** lpszArgv)

and from here there is no way to get the "Deployment Server/Deployment Server Extensions &  Managment Service" in a "running state".

  • 11 March 2021
  • SOTI MobiControl
  • 4 Answers
  • 0 Upvote
  • 2 Followers
  • 316 Views
    • 4 Answers
    • 0 Upvote
    • 2 Followers

4 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 11 March 2021

Try running the v15.3 installation .exe file again on your already upgraded server instance.

  • 0
  • 0
Remy | posted this 11 March 2021

Hi Raymond,

 

I've already tried that...also after an uninstall and a new install we have the same problem.

Do we "omit something"?

  • 0
  • 0
Remy | posted this 12 March 2021

Is this a "bug" in the JSON deserialization process?

  • 0
  • 0
JCMOD@SOTI | posted this 15 March 2021

Hi Remy,

 

If your DS / DSE is not operational, I suggest you raise a Support Case through support@soti.net / support.eu@soti.net. Alternatively, you can telephone Technical Support and receive assistance promptly.

 

Regarding the issue at hand. The difference between 15.1.3 and 15.3 is quite a lot, I suggest you double-check the System Requirements page for 15.3 and ensure your environment meets the specification detailed within.

 

If the above is fruitless, ensure you uninstall MobiControl via Control Panel. Double-check the MobiControl directory is empty in Program Files then perform a fresh install via running the installer exe.

 

Source: https://www.soti.net/mc/help/v15.3/en/setup/installing/system_requirements.html#installing_system_requirements

 

Let us know how it goes Remy, if you need clarification or have any questions feel free to reach out. If this helped resolve the issue, please mark this post as the solution.

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback