Adding Google Managed Corporate account to Android enterprise device

Adding Google Managed Corporate account to Android enterprise device

I want to add a corporate gmail account to devices which have been built under Android Enterprise.  

The option to add the account is disabled and with a popup saying to contact the mobicontrol administrator

there is no security option to enable (or disable for that fact) within Feature Control as I am used to seeing with an Android+ profile.

How do I allow the addition of another Gmail account?

14 Answers

Order By:   Standard | Newest | Votes
Matt Dermody | posted this 07 June 2018

What is your management use case (BYOD, COPE, COSU, COBO, etc) and how were the devices enrolled originally? Android Enterprise devices basically need to be enrolled as such during the initial startup wizard after a Factory Reset, assuming you're using a Managed Device model. Do you have a corporate domain bound to a Managed Google Account or are you using the newer concept of a Managed Google Play Account (MGPA)? 

  • 0
  • 0
Raymond Chan | posted this 07 June 2018

The Android Enterprise Feature Control payload in latest versions of v13.4/14.x MobiControl  does include option to allow adding Google account.  However, be careful whether adding your extra Google account will create any loophole related to unmanaged/personal apps associated with the account from Google Play store.

 

 

 

 

 

  • 0
  • 0
Eddie | posted this 07 June 2018

HI Matt These are corporate owned devices and we're using Managed Google Play account.

  • 0
  • 0
Eddie | posted this 07 June 2018

Hi Raymond. 

That's what I was expecting to see but there is no Disable Google account creation.

  • 0
  • 0
Raymond Chan | posted this 07 June 2018

As said earlier, you should see the option added in the latest patch versions of v13.4/v14.1.x.  You might need to consider applying such patch to your MobiControl server.

 

  • 0
  • 0
Eddie | posted this 07 June 2018

We're on 14.1.

  • 0
  • 0
Raymond Chan | posted this 07 June 2018

Your v14.1 server is probably not the latest ones.    v14.1.4.1693 definitely has that option.

 

  • 0
  • 0
Matt Dermody | posted this 07 June 2018

I'm seeing it available on 14.1.3.1587 as well. 

  • 0
  • 0
Eddie | posted this 08 June 2018

Our version is v14.1.0.1152 to be exact.  It's a cloud instance.  It was upgraded from 13.3.3 two weeks ago

Disable addition of new email accounts is there as an Android+ profile but not on Android Enterprise.

I'm going to create a fresh profile and see what (if anything) that does. 

  • 0
  • 0
Eddie | posted this 08 June 2018

For clarity This is what I'm faced with on the tablet.

 

  • 0
  • 0
SMod@Soti | posted this 08 June 2018

Hi Ed,

 

This feature was introduced in MobiControl v14.1.1 and higher. Hence, upgrading to latest MobiControl v14 build should resolve this issue for you.

 

Please let me know if any further information is required.

 

Thanks

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | soti.net |

 

  • 0
  • 0
Eddie | posted this 11 June 2018

Thanks for this confirmation (and to Matt and Raymond for their contributions)

I raised a support ticket on Friday about this but have yet to get a human response.  I will add the request to upgrade to the ticket.

I'll keep thread open until upgraded so you are all aware the the outcome.

  • 0
  • 0
Eddie | posted this 14 June 2018

Update as promised.

My server has just been upgraded to 14.1.4 and we now have the ability to add Google managed corporate email. 

Cheers

Ed 

  • 2
  • 0
Support Staff | posted this 29 May 2020

Hello VJ, 

 

Thank you for requesting a response from SOTI Support Staff.

 

I do not see any questions or details regarding your circumstances in this post.   So I will assume you are facing a similar situation. 

 

The answer has been provided and confirmed by the original post creator with the green "is solution" badge on the post.   Please follow their resolution or begin another post with your circumstances if further assistance is required.

 

Thank you Eddie for the confirmation that this has resolved. 

 

Cheers, 

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback