Adding MobiControl agent to battery optimization whitelist

Adding MobiControl agent to battery optimization whitelist

On Zebra TC75x and TC56 devices running on Android 7.1.2 Nougat with Lifeguard updates 11 and up, we noticed the MobiControl agent disconnecting from the server whilst the devices do have an active internet connection. When the device reboots, MobiControl does as well and stays connected for a few minutes but it'll disconnect soon after.

During the staging process of these devices, we add MobiControl to the battery optimization whitelist. We've tested this thoroughly and this works fine. Further testing proved that, once the device reboots, the setting will revert and MobiControl will be submitted to battery optimization and thus will be killed by Android to save power in x minutes, if not in use. Not maintaining this setting is problem 1.

Problem 2 is that the MobiControl agent will not reconnect after being killed by the battery optmimization process, unless you reboot the device. I must say we always have a Lockdown screen in place, that might have got something to do with it.

Any ideas how we can add the MobiControl agent to the battery optimization whitelist permanently?

  • Devices: Zebra TC75x, Zebra TC56
  • OS: Android 7.1.2 Nougat
  • OEM: 01-01-49.00-NN-U11-STD, 01-01-49.00-NN-U12-STD, 01-01-49.00-NN-U13-STD, 01-01-49.00-NN-U14-STD
  • MobiControl agent v13.5.1 Build 1234
  • MobiControl cloud version 14.2.0.2894

5 Answers

Order By:   Standard | Newest | Votes
Raymond, Chan | posted this 07 January 2019

While I don't have any Zebra TC75/TC56 to test out, I've encountered different device models from other brands with similar problem.  Have you checked what battery optimization option(s) you can configure in your device's "Settings"?   In some cases, one might be forced to turn off some or all power-saving mode(s) to prevent the agent from being stopped/killed.

 

According to the latest v14.2 online manual at  https://www.soti.net/mc/help/v14.2/en/scriptcmds/helpindex.html,  a new script command "batteryoptimize" has been added for Samsung MDM 5.7+ devices using v13.6 Android+/Android Enterprise device agents.  I hope there is similar support for Zebra and other device brands.

 

I suggest you to open an official support ticket with Soti and see if there will be similar support for your device and agent in the near future.  If there is no release roadmap or you can't wait, and you can trust your end-users, you can consider adding MobiControl device agent as an item in your lockdown menu, so that the end-user can, if needed, restart the agent by tapping on the lockdown item. 

 

 

  • 0
  • 0
Matt Dermody | posted this 07 January 2019

How are you adding MobiControl to the battery optimization whitelist? With a SOTI Profile or with a StageNow MX setting? Its possible that the application of the LG update (assuming that is performed after enrollment) is wiping out the MX setting? You might want to consider disabling Doze Mode entirely too as we've started to do that in some of our deployments.

  • 0
  • 0
Theun | posted this 18 January 2019

Thank you for your reply.

For Zebra devices, only the default Android battery optimization is applied (unlike Samsung). Upgrading to v14.2 might be worthwhile, I'll look into that. In the meantime, I've opened a support ticket and am working with a SOTI engineer to try and solve this issue.

As a workaround, adding MobiControl to the lockdown menu actually is an option for us. I hadn't thought of that. Thanks!

  • 0
  • 0
Theun | posted this 18 January 2019

I'm adding MobiControl to the battery optimization whitelist with a StageNow MX setting, yes. I've seen LG updates wiping these settings before, and we're already incorporating a second StageNow XML into MobiControl to re-apply them. Yet the issue of MobiControl leaving the whitelist also occurs when the device reboots. Whilst the two issues might be related, they seem different to one another.

Is it possible to disable Doze Mode entirely?

  • 0
  • 0
Matt Dermody | posted this 18 January 2019

Yes you can disable Doze Mode with MX or a Feature Control Package in newer SOTI versions.

  • 1
  • 0
Give us your feedback
Give us your feedback
Feedback