Android 8 Keyboard settings

Android 8 Keyboard settings

Hi.

we have to set "Keyboardsettings -> Text correction-> autom. Case sensitive-> disabled " in Android 8.

Is there a way to set it with script or config file?

11 Answers

Order By:   Standard | Newest | Votes
Matt Dermody | posted this 20 September 2019

You could try using watchsettings to capture the config change and then writesecuresetting to apply it. You might struggle on Android 8 though because I’ve had mixed success on AEDO. You could also check Zebra’s MX to see it those configuration options exist. I use Zebras EKB in most cases and it has similar settings as configurable options that are deplorable as MX from SOTI.

  • 0
  • 0
Rafael | posted this 23 September 2019

I send "watchsettings on" via skript to device but got "Watchsettings is not supported by the device" in protocoll. 

 

In mx settings i didn't found the setting. A colleague is looking for it in StageNow.

 

We found an alternative: Enterprise Keyboard (doesn't need this setting) BUT hoe to set it via skript?

I tried this: https://discussions.soti.net/thread/android-8-and-gboard/

But nothing happened.

  • 0
  • 0
Matt Dermody | posted this 23 September 2019

EKB is activated and configured via MX that you generate using StageNow, export as an XML file, deliver to the device via a Package or File Sync rule, then apply using the mxconfig script.

  • 0
  • 0
Rafael | posted this 23 September 2019

Is there no way to activate it with a "normal" script as in the link i posted above (doesn't work on Android 7 AND Android 8 here)?

What makes me wondering: I read often is use "watchsettings on" (protocoll: watchsettings not supported), i saw now "setlocale de" or "setlocale de_DE" doen't work anymore too (Android 7 its working fine, Android 8 -> protocoll: "setlocale not supported").

Tried to set it with mx too but no changes were made.

 

  • 0
  • 0
Rafael | posted this 26 September 2019

Problem solved by using another Keyboard.

  • 0
  • 0
Rafael | posted this 27 September 2019

Is there a way to DISABLE a keyboard? 

I want to disable:

com.google.android.googlequicksearchbox/com.google.android.voicesearch.ime.VoiceInputMethodService

 

I thought it's Solved with (one line):

writesecuresetting -sec enabled_input_methods com.google.android.inputmethod.latin/

com.android.inputmethod.latin.LatinIME:

com.symbol.mxmf.csp.enterprisekeyboard/com.android.inputmethod.latin.LatinIME

 

but now Android 8 devices are not working as expected. The Google Speachassistant is already active (when i send the skript manually it looks like its working very shortly but instantly reset), someone an idea?

  • 0
  • 0
Rafael | posted this 09 October 2019

I disabled the VoiceInput for the EnterpriseKeyboard now and this is working as well as disabling Google SpeachAssistant. But if someone knows which has to be different at 

writesecuresetting -sec enabled_input_methods com.google.android.inputmethod.latin/

com.android.inputmethod.latin.LatinIME:

com.symbol.mxmf.csp.enterprisekeyboard/com.android.inputmethod.latin.LatinIME

 

for Android 8 (in Android 7 it's working fine) i would be glad to read.

  • 0
  • 0
Matt Dermody | posted this 09 October 2019

When you send the enabled_input_methods script like this, you are leaving both the Enterprise Keyboard AND the default keyboard both enabled.

writesecuresetting -sec enabled_input_methods com.google.android.inputmethod.latin/

com.android.inputmethod.latin.LatinIME:

com.symbol.mxmf.csp.enterprisekeyboard/com.android.inputmethod.latin.LatinIME

 

If you only want the Enterprise keyboard enabled then you should just have the script like this:

writesecuresetting -sec enabled_input_methods com.symbol.mxmf.csp.enterprisekeyboard/com.android.inputmethod.latin.LatinIME

 

Granted, this assumes that writesecuresetting is even working on your Android 8 Zebra devices which has been somewhat of a crapshoot recently. The SOTI Agent needs to have the permission granted in order to have the ability to apply secure settings. That permission is seemingly granted by the installation of the OEM Plugin which from experience seems to be inconsistent in doing so. SOTI staff has indicated that version 1.16 of the plugin is needed in order to truly resolve the issue of having that permission silently granted but as of now only version 1.6 is hosted on the downloads page and 1.12 is hosted within the Plugin Service of newer MobiControl instances. 

  • 0
  • 0
Rafael | posted this 15 October 2019

But enterprise keyboard seem to need the standard keyboard (if you want to set it manually, the enterprise keyboard is greyed (too) if you turn of the GBoard.

The only thing is, i don't want to have the Google Speachassistant enabled (my solution for now is, to disable the button in enterprise keyboard settings) but its still active.

  • 0
  • 0
Rafael | posted this 16 October 2019

To "Granted, this assumes that writesecuresetting is even working on your Android 8 Zebra devices which has been somewhat of a crapshoot recently. The SOTI Agent needs to have the permission granted in order to have the ability to apply secure settings. That permission is seemingly granted by the installation of the OEM Plugin which from experience seems to be inconsistent in doing so. SOTI staff has indicated that version 1.16 of the plugin is needed in order to truly resolve the issue of having that permission silently granted but as of now only version 1.6 is hosted on the downloads page and 1.12 is hosted within the Plugin Service of newer MobiControl instances. "

 

We have this problem (have to set it manually), is there really no way to get the 1.16 or is there an update planned for the 1.6, so its granted silently?

We found out, that a reboot of the device sometimes does help but not everytime.

  • 1
  • 0
Kirsty Monk | posted this 04 December 2019

There is a 1.12 plugin available that allows you to enable writeSecuresetting silently?

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback