Android enterprise bindings

Android enterprise bindings

I had initially setup a personal email account that binded to our company name for a test a while back when learning android.

since it's my personal account how would I go about changing or binding to another google email account

can I just remove the binding and then bind to another account


when I'm in google play under Apps is the Organization Information, should I delete from there and then go to Soti and delete the binding?


two reasons I'm asking, 1) is because it's my personal email

2) when I deleted the binding from the soti global setting I noticed that when I went to enroll a new device it never went into "work managed device" it wanted to go in work profile which I didn't want, when I put the binding back it worked as desired


I'm using stageNow which is on my android devices


If I'm in soti mobicontrol and go to Android enterprise bindings and click on New, it takes me to google play and says "You have already signed up with this enterprise"

7 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 15 November 2020

A MobiControl server can have bindings with multiple Managed-Google-Play accounts (one account for each MGPA-enterprise).    You can add and bind a new non-personal  MGP account,  get  new add-devices and app-catalog rules assoicated with the new account, and check that everything is working fine.

Then just remove the old binding for your personal account.

  • 1
  • 0
larry | posted this 15 November 2020

ok, I'm under "global Settings" in soti, Android enterprise bindings and click on the wrench

then new managed enterprise, Managed enterprise enrollment dialog box says you are about to be redirected to googles managed enterprise enrollment page, when I click on ok it takes me to google play an says "you have already signed up with this enterprise"


I've googled and found a small section on "how to create and delete enterprises, I would rather find a way to add another account first rather than delete if possible


  • 0
  • 0
larry | posted this 15 November 2020

yes, I'm thinking that also

thanks for you help

  • 0
  • 0
Matt Dermody | posted this 16 November 2020

The Google Play error message you're getting is a byproduct of already being logged into the browser with the particular account that you're registering with. It has more to do with the account you're currently logged into Chrome versus the binding that exists in SOTI. 

  • 1
  • 0
JCMOD@SOTI | posted this 16 November 2020

Hi Larry,


Thank you for posting in SOTI Central.


I will detail instruction on how you can tackle this problem, if you need any clarification or have any questions. Then feel free to reach out.


1. Firstly ensure you're using MobiControl v15.1, this is for the "Reset Account" feature.

2. Logout of your personal Google account via

3. Navigate back to Global Settings -> Enterprise Bindings -> New -> Managed Enterprise

4. log in to your Google account that is affiliated with your company.

5. Setup the Enterprise Binding & optionally approve apps you need.

6. Now redirect back to Global Settings and then create App Catalog rules with the new binding, along with the correct apps.

7. Utilise the "Reset Account" function on your existing Android devices and select the new binding.

8. Once this is complete refer to the cleanup & additional tips below.


Cleanup & Tips:

  • Within your AE Binding, if you tried to remove it via Global Settings. There will be an error, this is likely because you've already associated the binding with an App Catalog rule. Remove the association by either deleting or disabling the necessary rules.
  • Once the above is complete, you could delete the old binding it via Global Settings and then navigate to and remove the Organisation too.
  • It is also recommended you set up additional Admin/s within the link above.
  • With the above instruction, you should be able to test this on a small scale first. Then once you're happy with the results, apply the same steps to your remaining Android devices.
  • Don't forget to update the Add Device Rule with the new binding.


Regarding devices turning into Work Profile instead of Work Managed Device. I suggest you double-check you're enrolling correctly. 


Hope this helps.



Technical Support | SOTI Inc. |1.905.624.9828 | | |

  • 1
  • 0
larry | posted this 22 November 2020

thank for the detailed approach you have outlined

I ended up calling Soti support and the tech walked me thru a different approach

Since we didn't really want to setup binding with google I went ahead and deleted the binding

then I reset the device back to factory default and when it came to google sign in I put in afw#mobicontrol which downloaded and let me install the agent, it's in work mode, remote control so that's what we needed


We are on version 15.01 and i've been wanting to upgrade, read where I need to get SQL up to version 2017 I beleive, anyway I can't get anyone to walk me thru the SQL express upgrade, everyone wants additional money for that. 

Back a couple of years ago I didn't manage to upgrade soti from v8 to v11 and had to upgrade sql so i know some guys out there know how to get me upgraded to the latest sql, I just need to find them.


I would like to upgrade to the newest soti version before I put a bunch of devices on this.




  • 0
  • 0
Raymond Chan | posted this 22 November 2020

You don't need to install the latest version of each component concerned in your system.   At the moment, most of my biggest customers demanding best possible stability are still using v14.5.x.   


If you deicde to upgrade to v15.x , you can use MS-SQL-2014 if you are upgrading to MobiControl v15.0.x or v15.1.x.  For v15.2.x+, you only need MS-SQL-2016.

Also, for MobiControl v15.0.x, the host O/S  should be either MS Server 2012R2 or 2016, but v15.1.x+ MobiControl should use MS Server 2016.  


For details, you should consult the relevant official documentation at



  • 1
  • 0

Give us your feedback
Give us your feedback