Android Enterprise - lockdown - Wi-Fi scan does not work

Android Enterprise - lockdown - Wi-Fi scan does not work

We are locking down Android Enterprise phones to a few onscreen buttons. One is for action://CONFIGURE_WIFI

We are finding that we are able to get to the settings and manually enter Wi-Fi name, but the scan does not work. Is there another corresponding setting that needs to be configured to allow the scan to work?

 

EDIT: The actual cause of this is that the Wi-Fi scan does not work if location is disabled. Not sure why this is related but have been able to confirm this by testing.

8 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 07 October 2019

Have you configured any options related to Wifi in Feature-Control profile payload?

 

  • 0
  • 0
Jake Ward | posted this 07 October 2019

I had done previously to mostly enable things, but I have now completely removed feature control and I'm still having the same issues.

  • 0
  • 0
Raymond Chan | posted this 07 October 2019

Feature Control profile payload should NOT be totally removed on Android Enterprise devices.  I am not sure if it is the same for all brands/modesl, many feature-control (restriction) options are enabled by default if no Feature-Control profile payload is deployed to an Android-Enterprise device.  

  • 0
  • 0
Jake Ward | posted this 07 October 2019

Ah, I see. I have added back feature-control to the profile but it has not resolved the issue. I am sure this was working at some point but I can't figure out what, if anything, has changed. 

 

Does the Mobicontrol app need to be given any specific permissions?

  • 0
  • 0
Raymond Chan | posted this 08 October 2019

Depending on the version of your Android Enterprise device agent,  you might need to check the app-manager tab of Settings to see if your MobiControl device agent has the following permissions granted :

  Change System Settings

  Apps that can appear on top

 

The first one may be the cause of your problem.   If not,  maybe other profile such as application-run-control, kiosk mode (advanced options) , authentication, etc. has been improperly configured.

 

 

  • 0
  • 0
Jake Ward | posted this 08 October 2019

Thanks for the suggestions. The app has been set up with those permissions.

  • application-run-control is not enabled.
  • Kiosk mode advanced settings are only to turn the on-screen home button off
  • Authentication is only set up to turn off a lock screen and set an admin password

I can't see any other settings that look like they could be related to this.

 

  • 0
  • 0
Jake Ward | posted this 08 October 2019

I have worked around this using the suggestions from here: https://discussions.soti.net/thread/settings-manager-for-android-enterprise/

 

It's not ideal as it gives access to more settings than I would like, but seems like the only way around this at the moment. I've done a lot of testing of different configurations and I'm fairly certain there is nothing in the profiles causing the issue so can only assume there is a problem with the agent.

  • 0
  • 0
Matt Dermody | posted this 09 October 2019

For what its worth, scan is working for me under the following conditions:

- AEDO

- Zebra Android Oreo (MC93)

- Locked down via legacy Activity Suppression (not AE Kiosk)

 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback