Android Enterprise - SSL handshake failed

Android Enterprise - SSL handshake failed

Hi,

We are currently testing some Honeywell CT40 devices (android 9 OS)

The device have a SIM card with data, but during enrollment it couldn't contact our Mobi server. As soon as I put it on wifi it connected to it and enrolled. I've also verified in the Mobi app, when you remove the Wifi and turn into network data there's SSL handshake errors and it get's disconnected.

The server is currently running with a SHA-1 certificate. We are expecting to update this soon, as were updating our fleet of devices.

Why there isn't SSL handshakes errors on Wifi and only on network data ?

Thanks,

3 Answers

Order By:   Standard | Newest | Votes
DDMOD@SOTI | posted this 08 June 2020

Hi Daniel,

 

Thanks for the post!

Can you please check if the external network to the MobiControl server is being blocked by Firewall or Antivirus installed?

If you are able to connect the devices to the MobiControl server on your local WiFi and experience 'SSL handshake failed' error only on mobile data, then this is certainly the network issue. Please have the network ports open.

 

Regards,

Technical Support | SOTI Inc. |+1-888-494-SOTI (7684) | support@soti.net | www.soti.net |

  • 0
  • 0
Daniel_Infra | posted this 08 June 2020

Hi,

The device is being tested from home with my wifi, which is external to our office network.

  • 0
  • 0
JVMOD@SOTI | posted this 09 June 2020

Hello Daniel,

 

Thank you for your response, please check with your network team if they have any restrictions for cellular network.

Also, try to disable firewall of the server and test the use case. If you are still facing an issue please let me know.

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback