Android Plus - How to disable swipe down to see notifictions ,wifi,blutooth, etc ?

Android Plus - How to disable swipe down to see notifictions ,wifi,blutooth, etc ?

Hi,

I have applied lock down in my Honeywell CT50 Android device in Android Plus mode.

But even in lock down mode, we can swipe down on the device and then the users will get access to turn on/off wifi,bluetooth,do not disturb mode,etc. 

I want to disable this option (Screenshot attached). 

How i can do this ? 

7 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 27 May 2019

Please note that NOT all Android-Plus agents can be configured to hide/disallow expansion of status bar in lockdown mode.  In fact, only a handful of brands support that.  If you have already checked the corresponding advanced option in the lockdown menu, and the status of the corresponding profile is "installed" for your test device, then it is very likely that the firmware of your device model does not support hiding/expansion of status bar.

 

 

  • 0
  • 0
Edgar Gomez | posted this 27 May 2019

Hi,

Make sure you check the Disable Status Bar Expansion.

We've worked with Honeywell devices and this should work.

  • 2
  • 0
Vikas | posted this 30 May 2019

Please note that NOT all Android-Plus agents can be configured to hide/disallow expansion of status bar in lockdown mode.  In fact, only a handful of brands support that.  If you have already checked the corresponding advanced option in the lockdown menu, and the status of the corresponding profile is "installed" for your test device, then it is very likely that the firmware of your device model does not support hiding/expansion of status bar.

 

Hi Raymod, 
This functionality is available for all android devices in the android enterprice mode ?

  • 0
  • 0
Raymond Chan | posted this 30 May 2019

I can't be sure if this is a minimum and mandatory feature available on ALL Android-Enterprise compliant device.  You have to ask Soti support team for an official answer.   My gut feeling is that, comparing with Android+ devices with such support,  there should be more AE device models supporting this feature, but I myself would not assume this feature is always available on ALL devices, not until I have performed sufficient number of tests on more brands and models.   I'd rather play on the safe side to manage my customers' expectation, rather than disappoint them if I bluff a feature that  doesn't really exist for sure.

  • 0
  • 0
Anthony Varela | posted this 20 August 2019

A work-a-round may be to simply remove the tiles from being viewed. You can send a script to allow for this.  The script can be placed into a "package" to run as a part of a profile also.

writesecuresetting -sec sysui_qs_tiles none

Be sure to review what tiles you have available currently should you have the need to reinstate them.

writesecuresetting -sec sysui_qs_tiles wifi,bt,cell,airplane,rotation,flashlight,location,nfc

  • 3
  • 1
Anthony Varela | posted this 20 August 2019

A work-a-round may be to simply remove the tiles from being viewed. You can send a script to allow for this.  The script can be placed into a "package" to run as a part of a profile also.

writesecuresetting -sec sysui_qs_tiles none

Be sure to review what tiles you have available currently should you have the need to reinstate them.

writesecuresetting -sec sysui_qs_tiles wifi,bt,cell,airplane,rotation,flashlight,location,nfc

  • 3
  • 1
Sean Vollmer | posted this 13 September 2019

Hi,

We also make use of CT50's and had the same issue.

We managed to get it working and in conjunction with what was posted by Edgar, you also  need to disable swipe down via your lock down in the deviceconfig.xml  using Honeywells Ezconfig.
The deploy the device config.xml file to all device.

You can also selectively disable what functions are availabale in the swipe down if you don't want to disable swipe completely.

Below is the section out of the deviceconfig.xml which you can edit that applies to the Swipe Down, Honeywell refers to it as "Quick Settings Menu"

<Section name="Quick Settings">
<Key name="remove_quick_settings_policy" desc="Set 1 to disable the quick menu, 0 to enable it" flags="16">0</Key>
<Key name="restrict_quick_settings_wifi" desc="Restrict WiFi in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_bt" desc="Restrict Bluetooth in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_do_not_disturb" desc="Restrict Do not disturb in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_cell" desc="Restrict Cell in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_airplane_mode" desc="Restrict Airplane mode in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_rotation" desc="Restrict Auto-rotate in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_flash_light" desc="Restrict Flashlight in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_location" desc="Restrict Location in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_cast" desc="Restrict Cast in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_brightness" desc="Restrict Brightness in quick menu.0=enabled, 1=restricted" flags="16" />
<Key name="restrict_quick_settings_multiuser" desc="Restrict Multiuser in quick menu.0=enabled, 1=restricted" flags="16">1</Key>
<Key name="restrict_quick_settings_settings" desc="Restrict Settings in quick menu.0=enabled, 1=restricted" flags="16">1</Key>
<Key name="restrict_quick_settings_battery" desc="Restrict Battery in quick menu.0=enabled, 1=restricted" flags="16" />
</Section> 

Simply change the 
>0</Key>
Variable to 1 to to disable that function and deploy to all devices into the following folder
\SDCard\honeywell\ezconfig

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback