APNS Changes

APNS Changes

Hi all, want to ask about this update regarding APNS :

Apple currently provides two endpoints for the Apple Push Notification Service (APNS): the original APNS endpoint based on a binary TCP protocol (hereafter referred to as “legacy APNS”) and a newer APNS endpoint based on the HTTP/2 communication protocol (hereafter “modern APNS”).

On November 1st, 2020, Apple will discontinue the legacy APNS in favor of the modern APNS. All versions of SOTI MobiControl released to date have leveraged the legacy APNS.  The discontinuation of the legacy APNS means that this change by Apple will impact all customers using SOTI MobiControl to manage their Apple devices.

As of November 1, 2020, customers will no longer be able to manage existing iOS & macOS devices or enroll new ones without upgrading their version of MobiControl.

SOTI will issue Maintenance Releases for SOTI MobiControl v14 and v15 in order to support the modern APNS and avoid any service disruption.  SOTI MobiControl v15.2 and higher will support the modern APNS and will not be affected when they are released.

Recommended course of action for affected customers

  • Customers running SOTI MobiControl 14.x or lower should upgrade to 14.5.1, which will be released in late May / early June, 2020.
  • Customers running SOTI MobiControl 15.0.x or 15.1 should upgrade to 15.1.1, which will be released in late May / early June, 2020.
  • Customers running SOTI MobiControl 15.2 or higher do not need to take any action.

For now my client used 14.4.1 version, if they plan to upgrade the version to 15.1, is APNS problem is solved for them? 

Thanks & regards,

Randy

4 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 09 July 2020

I can't see what's your problem from your post.  However, I believe what you need to know can be found in Soti's article at  https://discussions.soti.net/kb/apple-push-notification-service-apns-changes-impacting-soti-mobicontrol-customers

   

  • 0
  • 0
Randy, Saputra | posted this 09 July 2020

Hi Raymond,

 

Thank for answering.

Just want to make sure, IF my client want to stay at v14, they just need to upgrade to v14.5.1

But if they want to change to v15, they need to upgrade minimum to v15.1.1..

Is it right ?

 

Thank & regards,

Randy

  • 0
  • 0
Raymond Chan | posted this 09 July 2020

Hi Randy,

Based on the article, what you said is correct.

I myself am working with my customers in Hong Kong to upgrade their servers recently.  As I am not from Soti, nor do I  currectly have the right test environment to confirm that enrolled devices will stay under control after Nov 1 deadline,  I just trust what the article says is accurate unless there is newer official document from Soti in the future giving more updaed information otherwise. 

 

  • 0
  • 0
JVMOD@SOTI | posted this 09 July 2020

Hello Randy,

Thank you for your post, yes, you're correct. 

If customers running SOTI MobiControl 14.x or lower should upgrade to 14.5.1 and for customers running SOTI MobiControl 15.0.x or 15.1 should upgrade to 15.1.1

 

Also, if this post has helped you in solving your inquiry, I would request you to mark the particular comment as "is solution", so others may benefit from this information.

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback