Best Practice for Low Spec Devices (Soti Agent is getting killed by android)

Best Practice for Low Spec Devices (Soti Agent is getting killed by android)

Hello Guys,

 

has anyone of you encountered the Problem that your devices are running out of ram?

 

I.e. Android Plus Device with 1 Gb of Ram:

300 Mb Used by System

250 Mb Used by Soti

250 Mb Used by Other System Apps

-----------------------------------------------

= 200 Mb Free Space for other Apps

 

I observed that from time to time when our main app puts an extensive load on to the device, it runs out of ram and the system kills the soti agent:

I/ActivityManager: Process net.soti.mobicontrol.intermec (pid 860) has died

I know there is an option to run specific apps / services as "unkillable" , maybe the agent needs to get an update for this use case on low spec devices ?

But the main question is that i have for now, what am i maybe missing except for stripping down running apps and the soti device configuration itself to "save" ram.

Is there any config we can apply to not have the system kill the soti agent?

Has anyone experienced the same issue and what have you done to maybe solve it?

Kind Regards John

5 Answers

Order By:   Standard | Newest | Votes
SCMOD@SOTI | posted this 20 November 2019

Hi John,

Thank you for posting your question. 

I would recommend you to try Checking "Disable Doze Mode" Feature control. If you have MobiControl older than 14.2, Please try using the script:  

writeprivateprofstring DeviceFeature DisableDozeMode 0

apply featurecontrol

 

This will help the Device Agent to stay online all the times. Please try this out and see if this works for you use case.

 

Thank you.

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Raymond Chan | posted this 21 November 2019

While there is some limited control to request kernel not to swap an app out due to power management considereations, there is little one can do to stop an app from being swapped due to low memory. In pinciple, the device agent should be restarted automatically after a while.

To solve your problem, the best approach is to totally disable certain memory-hungry or redundant apps/services (especially those that are freely bundled with the device) via App Manager in device's Settings.

  • 0
  • 0
John Doe | posted this 21 November 2019

Thanks Raymond and SCMOD,

dozemode isnt exactly helping here, since the device(agent) isnt losing connection to mobicontrol.

The whole Agent is getting killed by android and is then automaticly started again, though maybe as "security feature" when the agent combined with the lockdown is loaded, it closes all previously or still opened apps.

So when the main app uses to much ram, soti agent is killed by android then automaticly restarts and lockdown then completly closes our app.

An option to not have kiosk closing previously opened apps would be useful in this case although its kind of a security risk.

 

I will try to further strip down the device with unneeded apps.

Kind Regards John

  • 0
  • 0
John Doe | posted this 22 November 2019

So apparently i missed something and you can somehow leverage foregroundmode via scripts:

Although i cant get it to work with DA and Agent 14.0.0.1579

 

Foregroundmode enable doesnt work

the example foreground enable doesnt work either

Kind Regards John

  • 0
  • 0
Scott | posted this 22 November 2019

'foregroundmode enable' works for me in DA mode with agent version 14.0.0.1579.  An icon appears in the notification area:

(It doesn't appear to work in AEDO mode)

  • 1
  • 0

Give us your feedback
Give us your feedback
Feedback