Block entire web domain?

Block entire web domain?

Is there a way to block an entire web domain rather than just a single URL? I have had success blocking a single URL in the Web Filter, but not entire domains.

 

Running: 

Android Enterprise

Zebra TC77

MobiControl 14.1

 

Thanks,

Jim

7 Answers

Order By:   Standard | Newest | Votes
JSMOD@SOTI | posted this 05 February 2021

Hi Jim,

 

Thank you for posting on SOTI Central.

 

This depends a lot on how the website is designed, but for example if you want to block 'soti.net/oem' you can add a Block rule for 'soti.net' in the Web Filter Profile.

 

If this doesn't work you might have more success by creating your own whitelist. You will need to add option type 'Block' and for the URL field, just put '*' in order to block all the other web sites. Then for each website you want to enable just add 'Allow' rule for the domains that you need to whitelist. However, this might not be feasible depending on how many websites you require to be accessible for the end user.

 

Alternatively, instead of using a Web Filter - which is specific to Chrome - you could use a SOTI Surf Profile and configure the Filtering option which allows you to use wildcards such as 'soti.*'.

 

I hope this helps.

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
JSMOD@SOTI | posted this 16 March 2021

Hi Jim,

 

Following up on this post, were you able to find a resolution in the end? If yes, please share the steps you took and/or mark the approriate comment as 'Solution' to help others find the answer.

 

Looking forward to hearing from you!

 

Many thanks,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Raymond Chan | posted this 17 March 2021

Hi Jim,

 

I have just checked the latest OEMConfig app from Zebra and could not find any configuration related to firewall settings (Samsung includes such configuration in the OEMConfig counterpart app "Knox Service Plug-In").  So, this aternative solution path is dead, at least for now.

 

Hence,  it seems that your only solution to block a full domain is to use a third-party secure browser (e.g. Soti Surf) wth such feature.  It is of course assumed that you have block other browser app from being run on the device.

 

  • 0
  • 0
Jim J | posted this 07 April 2021

It appears that the v15.3 UI does not allow the "*" in the URL field. It throws the error: The string is not a well-formed URL 

  • 0
  • 0
Raymond Chan | posted this 07 April 2021

MobiControl UI has NEVER supported using wildcard "*" or "?" in specifiying URL whitelist or blacklist in web filtering profile.  Bringing that up is misleading in the first place, and wasting anyone's time to try that out.

 

  • 0
  • 0
Jim J | posted this 07 April 2021

Raymond,

 

See the SOTIMOD reply above. I was providing feedback to that.

 

  • 0
  • 0
Joakim | posted this 09 April 2021

EDIT: This was the forum thread I created for my issue --> Web filter - Cannot use ruletype "Block" with URL " * " anymore (soti.net)

 

Actually I do use the wildcard "*" on the Webfilter to block all sites and then below that rule adding the only allowed websites we can reach on our devices. It hits on both SOTI Surf & Google Chrome. We use 15.2.2.1080

I did get the issue that Jim got when I upgraded from 14.3.3 to 15.1.0. It got resolved in one of the versions after that . I reported this as an issue and they said that it was a bug and would be resolved with 15.2 - Now I'm worried it will cause issues in 15.3 or greater version...

 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback