Bluetooth not working when in Managed Device mode.

Bluetooth not working when in Managed Device mode.

Hi, 

 

I'm trying connect a Zebra TC77 to a handsfree kit and it's not pairing. 

 

I've tried connecting the device to my laptop and my laptop produces a prompt for me to check matches on the device but on the device the is no prompt presented. 

 

Any suggestions? 

 

Thanks 

Josh. 

22 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 22 May 2019

Have you successfully deployed any profile with feature-control configuration payload to your problematic device?  If so,  what options  have been checked?

 

  • 0
  • 0
Josh Bradley | posted this 23 May 2019

Hi, 

 

I tried with no profiles assigned and only the kiosk and authentication assigned but no joy. 

 

Do you know if I need feature control as default to enable this to work? 

 

Thanks, 

 

Josh. 

  • 0
  • 0
Raymond Chan | posted this 23 May 2019

Are you using Android+ or Android-Enterprise device agent?

  • 0
  • 0
Josh Bradley | posted this 23 May 2019

Hi, 

 

Android enterprise agent. 

Agent version 13.7.2.1015. 

  • 0
  • 0
Raymond Chan | posted this 23 May 2019

I don't have any Zebra TC77 to do any tests, but for other brands using AE device agents, the USB mass storage is disallowed by default if no feature control profile payload is deployed. I'm just suspecting that there may be similar logic for bluetooth connection/pairing.  Perhaps you can perform a quick test and deploy a feature-control payload with bluetooth enabled (or "allow user to configure"  checked), and see if it make any difference.

 

  • 1
  • 0
Josh Bradley | posted this 23 May 2019

Hi, 

 

 

I've just tried this but still no joy. Tested on both the TC77 and TC57. 

 

Thanks 

Josh. 

  • 0
  • 0
RTMOD@SOTI | posted this 23 May 2019

Hi Josh Bradley,

 

Please try following script:-

afw_set_permission_grant_state com.android.bluetooth

android.permission.bluetooth_privileged allow"

 add_allow_app

 

Also, if these scripts do not work , then please confirm if Zebra application required for bluetooth pairing was blocked by vendor or not ?

 

Thanks !

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Josh Bradley | posted this 23 May 2019

Hi, 

 

This hasn't made a difference. 

 

I'm not trying to connect through an application, I'm in the settings trying to pair that way. 

 

Thanks

 

Josh! 

  • 0
  • 0
Matt Dermody | posted this 23 May 2019

Can you pair the handsfree kit to a completely Unenrolled and Factory Reset device? I would isolate SOTI and AE from your troubleshooting before going down a path investigating SOTI when it might be a device issue. 

  • 0
  • 0
Josh Bradley | posted this 24 May 2019

Hi Matt, 

 

Fresh out the box the device pairs, as soon as I put the device in Managed mode it doesn't work anymore. 

 

Thanks, 

Josh. 

  • 0
  • 0
Ivan | posted this 30 May 2019
Hi.
I have the same problem with Honeywell CT50-60 terminals.

With the agent AE and in managed device mode, the bluetooth does not link.
  • 0
  • 0
Josh Bradley | posted this 30 May 2019

Hi Ivan, 

 

I've now overcome this issue after speaking with Zebra. 

I had to send this script "enable_system_app com.zebra.bluetooth"

 

Once done, the prompt then began to appear to accept the pairing to another device! 

 

The bundle ID will be specific to you device though so you'll have to look through the applications tab to find the right one. 

I took me a couple of guesses before I got the correct bundle ID! There's a picture attached of what the Bundle ID looked like for me. 

 

Hope this helps! 

 

  • 0
  • 0
Johan W | posted this 04 July 2019

I can also confirm that enable_system_app com.zebra.bluetooth fixed our problem on Android 8 and Managed Device.

On Android 7 the app is not blocked.

 

Thank you!

  • 0
  • 0
Matt Dermody | posted this 04 July 2019

You are going to find that there are ton of Zebra System Applications that get disabled by default when enrolling as a Managed Device. This is a function of Android Enterprise and isn't really a bug, just something to watch out for. If you use StageNow based DO enrollment however all of the System Apps remain enabled so you don't have to re-enable them with the script. Thankfully SOTI at least has a script for enabling System Apps but its often hard to tell just which apps have been disabled until you run into an issue like this with Bluetooth. 

https://discussions.soti.net/thread/does-anyone-have-zebra-tc-57-android-8-1-oreo-and-running-soti-effectively-with-kiosk-lockdown/

  • 0
  • 0
Bless | posted this 19 September 2019

Good day

 

I am facing the same challenge. I have enabled tha app as above but the pop up does not appear under lockdown. I can hear the notification sound. If i remove the lockdown and pair the device using the main settings button, the pairing popup with the passcode appears.

How do I enable to pop-up with the PassCode to be displayed under lockdown of AE?

 

  • 0
  • 0
Raymond Chan | posted this 19 September 2019

I don't have the hardware to perform any tests, and solutions might depend on the brand/model.   However, the general approach is to find the name of the activity associated with the pop-up, and have it white-listed in the kiosk.

 

 

  • 0
  • 0
Support Staff | posted this 19 September 2019

Hello Josh, 

 

Thank you for requesting a response from SOTI Support Staff, 

 

Try sending the Identify_activity script to the device while the lockdown is disengaged and while the Bluetooth pairing screen you desire is open on the device.  (In Android Plus I have also had to enable data usage access for MC in Android's other security settings).   The result of this script should be available in the logs after the device has reported back.   Then you can use that ID in the lockdown and it should allow it through the lockdown.

 

I have been advised that the Identify_activity script doesn't always work with all AE versions.  If that is the case, try using ADB logging to capture the bundle ID and then add that to your lockdown list.

 

com.android.bluetooth may be the correct ID but it may not be the full ID needed to authorize this.

 

Hope this helps some, 

 

 

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Patrick | posted this 03 October 2019

I am having the same issue as Bless. We have a TC57 with the Zebra Bluetooth app enabled, but the pairing script does not come to the top when pairing with a Bluetooth enabled printer. 

The device is an AEDO in Kiosk mode. I can see the pairing script come to the top when in Admin mode. 

Need to find a script that will allow the pairing script to come to the top. 

  • 0
  • 0
Matt Dermody | posted this 03 October 2019

Did you try the suggested steps?

Enter Admin Mode and try to identify the activity when the pop up appears so that you can then whitelist that particular activity in the lockdown. 

  • 0
  • 0
Tom Little | posted this 4 weeks ago

Hi. By using the identify_activity I was able to grab the following ID from the logs "com.android.settings/.bluetooth.BluetoothPairingDialog". If I add this ID to the Lockdown program list the pairing code message will successfully appear when attempting a BT connection via MobiControl Setting Manager app. The problem now is that the device settings app is on the lockdown page and can be accessed. Is there another way to whitelist this?

  • 0
  • 0
Support Staff | posted this 4 weeks ago

Hello Tom, 

 

Lots of different versions of a similar issue happening in this post.  

 

Try viewing the HTML for the lockdown and remove the reference to the icon only, for the "bluetooth pairing"  you provided in the lockdown image.  

 

Hope this helps

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Tom Little | posted this 4 weeks ago

Hi, yes that worked well thank you.

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback