Data Collection Rule for iOS not working

Data Collection Rule for iOS not working

We're currently running our SOTI instance on Version: 15.2.3.1033, and attempted to setup an iOS Data Collection rule to pull geolocation data on a set of iPads enabled with cellular data. Data collection is only appearing under device information once the agent is launching. What needs to be configured so that the rule queries these devices ever so often for the geolocation data to be recorded instead of having to open the iOS SOTI app?

7 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 28 January 2021

Please provide more details:

 

1. What is the iOS firmware version of your iPAD's?

 

2. Are they in supervised mode?

 

3. Are they enrolled in BYOD mode using managed AppleID?

 

4. Have you granted MobiControl permission to ALWAYS have location access in the device Settings->MobiControl->Location  tab ?    Of just selected the option "While Using The App"?

  • 0
  • 0
R. Robles | posted this 28 January 2021

All our devices are in supervised mode and are disabled to not use Apple IDs. I have gone into MobiControl settings to enable Always on for location services. The two devices that use cellular data are on iPadOS 14.1 or 14.3.

  • 0
  • 0
Raymond Chan | posted this 28 January 2021

I did my test on my iPad on hand, and everything works fine, though my iPAD firmware version and MobiControl server version are both different from yours.

 

Have you checked the "Collected Data" log for data.  As the data is cached in the device buffer and transferred back to your server in burst at interval out of your control,  you might need to wait patiently, and press refresh button and/or flush the cache in MobiControl Sync module to get the collected data displayed.

 

  • 0
  • 0
R. Robles | posted this 28 January 2021

The only records displayed under the Collection Date tab are records when the end user opens the MobiControl app. It's been 24hrs+ since I've applied this rule, which is why I waited before posting, thinking it might be on a default timed interval.

  • 0
  • 0
Raymond Chan | posted this 28 January 2021

Have you checked the option "Report location data to the server in the background" in the Accuracy tab of your data-collection rule?

  • 0
  • 0
R. Robles | posted this 28 January 2021

Report location data to the server in the background is enabled, and Optimal Location Accuracy is enabled. 

  • 0
  • 0
Raymond Chan | posted this 29 January 2021

Is there a possibility that the device configurations I asked about in earlier posts get modified without you knowing?

If they are verified to be exactly as you said, then maybe you should explore if the problem comes from device firmware or your MobiControl server.   

 

Maybe you can first test again using device of different firmware version on your server.   If the result is negative,  you can then open an official support case with Soti support team, and get your device enrolled and tested on their MobiControl server of version different from your current v15.2.3.1033.  My successful result on iPAD  running 13.4.1 firmware was obtained using MobiControl v14.5.5 server.

 

 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback