Datawedge files in Zebra device

Datawedge files in Zebra device

Hello,

I have several Zebra devices (TC20, TC25, TC26 ...), for which I have created different profiles (Android Enterprise) in Kiosk mode (Lockdown).

In all of them, I install Datawedge and the configuration profile, using a package

The thing is, I can't get the profile to copy correctly to the location I want, so that it self-applies.

Routes: (Image1)


Source: D:\_SOTI_\DEVICES\PDAS\TC25\Configs\Datawedge\dwprofile_TC25.db

Target: /enterprise/device/settings/datawedge/autoimport/datawedge.db

or

Target: %sdcard%/Android/data/com.symbol.datawedge/files

I can't get this file to be copied to the specified destination!

I also tried to perform a rule and it does not transfer to the desired location either. (Image2)

 

Thanks

■------------

Hola,

Tengo varios dispositivos Zebra (TC20, TC25, TC26...), para los que he creado diferentes perfiles (Android Enterprise) en modo Kiosco (Lockdown).

En todos ellos, instalo Datawedge y el perfil de configuración, mediante un package

La cuestión es que no puedo hacer que el perfil se copie correctamente a la ubicación que yo deseo, para que se autoaplique.

Rutas: (Image1)
Source: D:\_SOTI_\DEVICES\PDAS\TC25\Configs\Datawedge\dwprofile_TC25.db

Target: /enterprise/device/settings/datawedge/autoimport/datawedge.db

or

Target: %sdcard%/Android/data/com.symbol.datawedge/files

No consigo que este fichero se copie en el destino indicado!

También intenté realizar una regla y tampoco se transfiere a la ubicación deseada. (Image2)

Gracias!

___________________//______________________

Image1

MCSTUDIO_Package_1

Image2

SOTI_Rule_1

 

3 Answers

Order By:   Standard | Newest | Votes
Matt Dermody | posted this 21 June 2021

DataWedge .db files are auto-consumed as soon as they hit that particular autoimport directory so it is possible the files are making it to the device but are being consumed and disappear by the time you go to inspect the folder to see if they are there. 

 

I recommend a package that places the .db file in the following directory and then a post-install script to make sure the file has the right read/write permissions set. Without the post-install script you'd likely need to have the device(s) rebooted before you see the profiles appear. 

 

 /enterprise/device/settings/datawedge/autoimport/datawedge.db

 

Post-Install:

 

__chmod 777 /enterprise/device/settings/datawedge/autoimport/datawedge.db

 

https://supportcommunity.zebra.com/s/article/Deploy-DataWedge-for-Android-Configuration-using-SOTI-MobiControl?language=en_US

  • 3
  • 1
GMFOOD | posted this 25 June 2021

Thanks.

Before posting the query, I had already configured a package and postscript

The package sends datawedge.db and dwprofile_TC25.db to the com.symbol.datawedge / files folder and after copying them to AUTOIMPORT it applies chmod 777 to them.

I hadn't checked it until today, and I have found that it did work.
Anyway, thank you very much for the input. Perhaps it is simpler as you indicate. I had the doubt that the package did not reach the Autoimport folder since, on other occasions, it had not worked for me (perhaps chmod was missing)

Thanks fo all!

_________

Gracias.

Antes de postear la consulta, ya había configurado un paquete y postscript

El paquete envía datawedge.db y dwprofile_TC25.db a la carpeta com.symbol.datawedge/files y luego de copiarlas a AUTOIMPORT les aplica chmod 777.

No lo había comprobado hasta hoy, y me he encontrado que sí funcionaba.
De todos modos, muchas gracias por el aporte. Quizás sea mas simple como tu indicas. Tenía la duda de que el paquete no llegase a la carpeta Autoimport ya que, en otras ocasiones, no me había funcionado (quizás faltaba chmod)

Gracias!

  • 0
  • 0
Matt Dermody | posted this 25 June 2021

For Android Enterprise Zebra devices you need to use this chmod script and not the execute_shell command that you are using. 

 

__chmod 777 /enterprise/device/settings/datawedge/autoimport/datawedge.db
  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback