Device stuck on Google account

Device stuck on Google account

Hi. I have a trouble with enrolling devices to my SOTI server.

Here is a screenshot with messages which I can't get rid of and enroll any device, using google mdm account in SOTI.

Device: Samsung J5
Android version: 9
Knox version: 3.4
Playstore version: 22.4.25-21
Soti Server version: 15.1.0.3413
Soti mobile version: 14.1.4 Build 1010

At the beginning, there were any problems with enrolling device. I've could enroll more than 50 device in the same day.
Later, only 10 a day. Next day there were no problems to continue enrolling.
After few weeks, only one device a day.
Now, I can't enroll any device. Sometimes, I need to wait few days, sometimes more than a week to enroll.
This problem started from June and still persist.

There is no any problems with SOTI license or Samsung ELM, because device is always succesfully enrolled without google account.

 

What i've tried:
- create a new rule with another mdm google account and enrolling device: success.
- enroll device without google account: success.
- reboot server, reboot device: still not working.
- check if hash for mdm google account is the same. Are the same, but device still stuck in same message.
- enroll devie in another server and without google account: success.


Is there any google account limitations for how much devices you can enroll via MDM?

Thanks.

5 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 26 October 2020

I don't think there is any limit.  I have customers with a few thousand AE work-managed devices enrolled

  • 1
  • 0
Alexey, Stepanov | posted this 26 October 2020

You mean using managed google play account?

I'm using a managed google play account, and in SOTI help tells:

"Once the device connects to the enterprise, a managed Google Play account is automatically created within the associated enterprise and applied to the device."

Perhaps it stuck in part, where it automatically creates google play account?

There is no problem with internet or firewall and I can't delete organization in android and put it one more time to android organization biding in SOTI, because it would harm all enrolled devices.

  • 0
  • 0
Raymond Chan | posted this 27 October 2020

Yes.  I meant managing thousands of AE devices under one Mnaged-Google-Play account.

 

From your descriptions, it seems that ALL devices enrolled in previous months are under perfect control and the only problem is enrollment of more devices.   Have you tried enrolling devices of other brand/model(s) or Samsung J5 with different firmware version(s) from those that fail to enrol?   What enrollment method did you use?  Have you upgraded your MobiControl server in the last few months?  Have you checked various MobiControl server log files to get more information about possible problems?

 

 

 

  • 0
  • 0
JCMOD@SOTI | posted this 27 October 2020

Hi Alexey,

 

Thank you for requesting a response from SOTI Support Staff.

 

You need to upgrade your MobiControl Version, that build had an issue with AE Enrollment. It sounds exactly like your issue. If you navigate to https://docs.soti.net/soti-mobicontrol/release-notes/ and look under 15.1, you'll see your build is replaced by 3416.

 

If this resolves your issue please mark this post as resolved.

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 1
  • 0
Alexey, Stepanov | posted this 30 October 2020

After upgrade my MobiControl to build 3416 my problem was fixed.

I've tried with Samsung, Zebra, and LG devices. Everything works great and each enrollment is always successful.

 

Thanks for your help!

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback