Devices stuck at "configuring google account" pending action

Devices stuck at "configuring google account" pending action

Hi, 

We have recently started staging a number of Android devices with Managed Google Play accounts, and today found that all of the devices were getting stuck for quite a long time at the pending action "configuring google account" phase of staging. 

We have staged a handful of devices at a time before with the odd device struggling at that bit, but never have we had the entire lot grind to a halt! 

Is this something people have seen before?

7 Answers

Order By:   Standard | Newest | Votes
Allen Gulbrand | posted this 22 October 2018

Ha. Try this. Go to the settings>accounts>Remove the account that is there. Click user action pending and tap the google one a few times. Does it go away?

  • 2
  • 0
Edgar Gomez | posted this 22 October 2018

Hello

I´ve seen that, depending on the device version, it needs to update Google Play Store and Google Play Services, before it configures the Google account for the device. So it may take long if you have a lot of devices connected to the same wifi.

  • 2
  • 0
Raymond, Chan | posted this 23 October 2018

On top of Wifi congestion suggested by Edgar,  Google's server supplying the required service modules may sometimes be the bottleneck.  It can be due to network loading/maintenance of Google's server serving your region, or due to upgrade/maintenance of the service module(s) themselves.  

 

Previously, we encountered similar problem.  We could do nothing extra on the devices, but they all eventually got updated when we powered them up again two days later.

 

  • 2
  • 0
Andy Halkyard | posted this 25 October 2018

Thanks to you all for your responses, sadly it looks like a Server side issue and SOTI are looking into it now for us. 

 

  • 0
  • 0
Øystein, Stakvik | posted this 16 November 2018

Hello Andy

What was needed to be fix in this case?
We are deployig MobiControl v14.1.8 in a closed enviroment and are getting the same issue on Android 6 units.

MobiControl at first we had to set Global Proxy settings so it would reach both Google and Soti Services but units themself are in a closed network.

I belive units needs to connect to Google Services to update whit correct version and such.
Do you have any information you could share about the solution?

 

 

  • 0
  • 0
Laurent, NACHBAUER | posted this 16 November 2018

Hi,

For the enrollment process you need access to the internet on the devices, if you don't, you can use the master phone with the staging app with cellular sharing, and once you got through to the desktop, switch to the wifi that has access to mobicontrol.

You can then switch back to the cellular network to update google services and after that again on the corporate network to have everything set on the mobicontrol side.

Many steps, but it will eventually get you there.

Android enterprise is meant for devices that can access google services. You can get it to work otherwise, but you will be limited. The use of a corporate play store won't work without the devices accessing google. Instructions are sent from mobicontrol to google, and then google will push to the devices.

Standard provisioning like packages, scripts, messaging and remote control will still work of course.

  • 0
  • 0
Johan W | posted this 6 days ago

This actually solves the problem very good!

  • 0
  • 0
Give us your feedback
Give us your feedback
Feedback