Disable Play Protect on AEDO TC52 (Oreo)

Disable Play Protect on AEDO TC52 (Oreo)

Is there a method for disabling Play Protect beyond these two scripts? I have tried both on an AEDO TC52 and neither seem to disable Play Protect. I am running Agent version 13.7.0 Build 1031.

 

writesecuresetting -glo package_verifier_user_consent -1



writeprivateprofstring DeviceFeature DisableVerifyApps 1

apply featurecontrol

6 Answers

Order By:   Standard | Newest | Votes
RTMOD@SOTI | posted this 14 May 2019

Hi Matt,

There is an option under feature control profile configuration " Disable verify Apps Enforcement" under "Security" . This feature does not disable Google Play Protect, it just allows the device User to turn it off manually (hence the manual User interaction required). If that is what you are trying to achieve.

Please let me know if it works for you.

Thanks !

 

 

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Matt Dermody | posted this 14 May 2019

Yes, I'm familiar with that option in Feature Control and thought that it might have been interfering with the scripting options at first but the scripts don't work with or without that option enabled. watchsettings also doesn't work with the AEDO devices so I'm not able to monitor and reverse engineer a writesecuresetting option to disable Play Protect either. Is this a functionality that we can expect in the future or is there a limitation in Android that limits a potential solution?

  • 2
  • 1
Rob Morrison | posted this 12 July 2019

I'm in the same boat. We have an internal app that won't install on our devices and it appears as though it is because of Play Protect. Having a feature to disable Play Protect would be huge. 

  • 0
  • 0
Matt Dermody | posted this 12 July 2019

I still haven't had any success with this myself. 

  • 0
  • 0
Josh Bradley | posted this 10 March 2020

Hi Matt,

 

Any success with this? 

  • 0
  • 0
JVMOD@SOTI | posted this 10 March 2020

Hello Matt,

 

Thank you for your post, 

Did you try enabling Installation from Unknown Sources from the feature control profile?

Let me know if that works for you.

 

Also, 

Here are some possible resolutions you can try:

 

1. Appeal the 'malicious' application with the Google Play Team through this form (https://support.google.com/googleplay/android-developer/contact/protectappeals)

2. Upload the application to Google Play which will notify you about some of the criteria that is causing the application to be marked as malicious. Then resolve the issue (usually related to updating the application code) and attempt to push down application via package again.

3. Turn off “Verify Apps” enforcement feature control under the “Android Enterprise” profile type. Then toggle the scanning in Play Protect scanning.

 3.1 If “Unknown Sources” is enabled on the device, then GPP is significantly more aggressive in its scanning and flagging of applications being installed

4. Upload the application through the Managed Google Play Store as a private application

  4.1 GPP will run significantly less checks for the app since it is being uploaded from a trusted source (i.e. the Managed Google Play Store)

   4.2 Uploading through the Managed Google Play Store will also warn the Administrators of vulnerabilities and best practices for their applications.

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback