Duplicate Device Enrollments

Duplicate Device Enrollments

I'm noticing that a number of devices are starting to enroll as duplicates in a new environment that I'm managing. Has anybody encountered anything like this?

Server: 14.2.2.1170

Agent: 13.6.0.1567

Management: Android Enterprise - Device Owner

Enrollment Method: StageNow - Agent Install + mcsetup.ini + MX based 

I take it that it might have something to do with my Enrollment method but I'm not sure how to prevent it or remedy it now. 

 

7 Answers

Order By:   Standard | Newest | Votes
Raymond, Chan | posted this 20 February 2019

You could try one or more of the following:

1. Delete the device icon (e.g. after wipe or unenroll action)  before re-enrollment 

2. Tick the "Preserve Device Name on Re-Enrollment" in the Advanced tab of your Add-Devices rule.

3. Tick the "Enable Strict Android Re-Enrollment" option in "Enrollment Settings" in the All-Platforms tab,

 

 

  • 2
  • 1
Jason Klotz | posted this 20 February 2019

Matt - I use the #2 approach ( what Raymond listed ) on my enrollment rules. I have had great luck with not getting duplicates. It is almost like your enrollment did a double dribble there.

  • 1
  • 0
Matt Dermody | posted this 20 February 2019

Thanks Gents! I already had suggestion 3 enabled, but not suggestion 2. Hopefully that remedies any issues with future enrollments.

 

Any suggestions for remedying the devices already in this state? Selecting one of them automatically selects both:

 

  • 0
  • 0
Jason Klotz | posted this 20 February 2019

Can you unenroll? Delete both and re-enroll and see if you only get one?

  • 0
  • 0
Matt Dermody | posted this 21 February 2019

Interestingly the issue just seemed to eventually remedy itself. The duplicate device just disappeared after an hour or so, without any intervention needed. 

  • 0
  • 0
Samuel | posted this 21 February 2019

Hi Matt,

Even this problem solved by itself, we had this issue and you can solve it forcing the sync of the Mobicontrol Search Service. You can do this in the configuration of the Interval, pressing Sync Now. I guess, your server synched by it's normal schedule and your problem was solved.

  • 1
  • 0
Matt Dermody | posted this 21 February 2019

Great point! I bet that was it considering that it seemed to resolve itself. 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback