"Duplicate Device ID" error when trying to re-enroll a deleted device.

"Duplicate Device ID" error when trying to re-enroll a deleted device.

I have two Zebra VC80X devices that I deleted from the management console and performed a factory reset on each.

Now when I try to re-enroll them with MobiControl Stage they are both getting a "Duplicate Device ID" error and they won't enroll.

I checked and rechecked that the devices have been deleted from the management console so I'm at a loss as to why it keeps saying Duplicate Device ID.

Please help.

4 Answers

Order By:   Standard | Newest | Votes
Nathan Davis | posted this 29 October 2019

I found the issue.

The MobiControl Stage installer that I was pushing to the devices was assigning the same Device ID to each unit.

The solution was to download the full agent from the server and push it directly to the devices thereby bypassing the MobiControl Stage installer.

  • 1
  • 0
Premnath | posted this 29 July 2021

Hi Nathan. Can show me some steps how you did that?

 

The solution was to download the full agent from the server and push it directly to the devices thereby bypassing the MobiControl Stage installer.

  • 0
  • 0
Nathan Davis | posted this 28 October 2019

I just recently upgraded to version 14.4.4.1045.

I went into the Global log settings and made sure that the option to permanently remove all records of a deleted device from database was already checked.

In the Advanced tab of my Add device rule I have the following checked:

Enable Rule

Preserve Device Location on Re-Enrollment

Publish to Enrollment Service

Preserve Device Name on Re-Enrollment

 

I also just tried adding a new device that's never been enrolled and it's also getting Duplicate Device ID.

  • 0
  • 0
Raymond Chan | posted this 28 October 2019

What are the version and build numbers of your MobiControl server?  Have you recently upgraded your MobiControl server?  Please note that more recent versions have option to permanently remove all records of a deleted device from the database.

 

Also, check the options you've chosen in the advanced tab of your add-devices rule to see if you have set any conflicting options.

 

 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback