Enable Google's Location Service Remotely

Enable Google's Location Service Remotely

I am trying to get location services set up on my TC70x devices. They are running Android 8.1.0 with Android Enterprise. I have set Location Accuracy to Battery Saver in Feature Control. After I deployed this to my test devices I got this pop-up:

On one device I clicked "Agree" and the location tab SOTI was able to immediately locate the device. On another device I did not click anything, and later clicked Disagree and for both SOTI was unable to locate the device. 

 

Is there a way for me to turn on this setting remotely with a script or something? I cannot rely on users to click Agree on all the devices. 

 

Thank you!

9 Answers

Order By:   Standard | Newest | Votes
SCMOD@SOTI | posted this 06 November 2019

Hello Kyle, 

Thank you for your question.

You are seeing this because, the Google Location Services on the device is not toggled on. To simplify it, Go to device settings, type "Location", look for "Google location services".

Once you toggle it on you wont see this pop-up.

This will solve your issue.

Thank you.

 

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Kyle Mullins | posted this 11 November 2019

Having to go to device settings and turn this on manually is my whole issue. I have devices in plants all around North America and these plants do not have IT people or anyone to do this manually. My post was asking how to do this with a script or something. 

  • 0
  • 0
SCMOD@SOTI | posted this 11 November 2019

Hello Kyle,

 

Thank you for your response. 

Please try using "High Accuracy" in Location Accuracy in Feature Control.

 

Hope this works for you.

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Scott | posted this 11 November 2019

Turning on High Accuracy will result in a different but similarly problematic dialog that grinds things to a halt until dismissed.  Zebra provided me an apk that enabled high accuracy and then silently dismissed the resulting Google dialog, resolving the issue for me.  I'm not sure if I'm allowed to publish it as there might have been some legal "you agree to this" stuff.  I can't remember.  You might just get in contact with your Zebra SE and see if they can give it to you.

  • 0
  • 0
Kyle Mullins | posted this 13 November 2019

Does this APK work on multiple devices across multiple OS versions for you? Also do you know who at Zebra gave it to you? I could reach out to them. 

 

Thanks for the help!

  • 0
  • 0
Scott | posted this 13 November 2019

I've only used it on 7.1.2.  I expect it would work with most Zebra devices but I only have the TC56.

I went back through my emails and I did have to agree to Zebra statement before obtaining the apk since they are accepting Google conditions on our behalf.  I would contact your Zebra SE and ask about "ECRT_35736_Enable_Location.apk".  Essentially, it accepts an intent that specifies which location mode to set and then silently accepts the resulting Google prompts.

Good Luck

  • 0
  • 0
Kyle Mullins | posted this 10 December 2019

Scott, I tried to send you a message but it would not send so I thought I would send it here:

 

I saw you asking about input methods and only having one enabled. I ran into this issue where I had the Zebra Enterprise Keyboard enabled but users could still click on the Globe icon and switch input to the Gboard. I got around this by doing the following:

I have this piece of XML that runs as part of my normal device settings XML script (It enables Enterprise Keyboard) -
<characteristic version="8.2" type="UiMgr">
<parm name="InputMethodAction" value="1" />
<characteristic type="InputMethodDetails">
<parm name="InputMethodOption" value="4" />
<parm name="InputMethodPackageName" value="com.symbol.mxmf.csp.enterprisekeyboard" />
<parm name="InputMethodClassName" value="com.android.inputmethod.latin.LatinIME" />
</characteristic>
</characteristic>
Then I have a package in SOTI that runs this XML (It disables Gboard) after the script above - 
<wap-provisioningdoc>
<characteristic version="8.0" type="AppMgr">
<parm name="Action" value="DisableApplication" />
<parm name="Package" value="com.google.android.inputmethod.latin" />
</characteristic>
</wap-provisioningdoc>

A restart happens as the last piece of my profile and then when the enterprise keyboard is up the globe icon is gone and the users cannot switch profiles as the enterprise keyboard is the only one enabled.

Not sure if you already figured this out but I figured it couldn't hurt to share.

  • 0
  • 0
Scott | posted this 10 December 2019

Yes, you can use MX to disable the other possible input methods, assuming you know what the other possible apps are (and what I will do if necessary).  I was just looking for the equivalent functionality we had with A+.  That way I don't have to keep track of and disable 2 or 3 other applications, I just specify the one handler I want running and not worry about any others.  Thanks!

  • 0
  • 0
SCMOD@SOTI | posted this 17 December 2019

Hello Kyle,

Hope this finds you well.

Did you find the solution of your post. If Yes, Can you please "solution" the answer which fixed your issue.

 

Thank you.

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback