Enable OS Upgrade on Samsung Devices

Enable OS Upgrade on Samsung Devices

Hi,

I'm using SOTI V13 with Android devices (Samsung Xcover) and I would like to enable OS auto-update on all devices.

Is there a script to  do it?

On most of devices the OS Auto-update field is not checked and a lot of devices can't have the last update of Androïd OS.

 

Many thanks for your help.

 

BR

 

Farid

7 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 28 March 2019

What is the Android firmware version of the devices?

Are you using Android Plus or Android Enterprise device agent on such devices?

  • 0
  • 0
Farid.S | posted this 28 March 2019

Hi Raymond,

 

I'm using Android+, the current firmware is 4.4.4 and devices are SM-G388F.

I would like to upgrade to OS 5.1.1.

 

Thanks

  • 0
  • 0
Raymond Chan | posted this 28 March 2019

For this relatively old Android firmware version, you can try sending the following script to your devices:

 

  writesecuresetting -sys SOFTWARE_UPDATE_AUTO_UPDATE  1 

  writesecuresetting -sys  FOTA_CLIENT_POLLING_TIME   1553783180000

  • 0
  • 0
Farid.S | posted this 28 March 2019

Hi Raymond,

The box "auto-update" is now checked!

But is it possible to order the update in the same time and of course the installation?

I had to do it manually.

My goal is to have a script which will make devices auto-update in a first time and in a second time to have a script to install the new OS.

Many thanks

FARID

 

  • 0
  • 0
Raymond Chan | posted this 28 March 2019

That is likely not possible for your case.  Remotely forcing a SILENT firmware update requires Samsung E-FOTA, which  is supported on Samsung devices running Android 7.0+ with Samsung Knox 2.71+, and E-FOTA license purchased from authorized reseller.  Also, your MobiControl server has to be at least v14.1.5.

  • 0
  • 0
Farid.S | posted this 29 March 2019

Hi Raymond,

If I'm not wrong to update and install automatically OS updates we need to switch from V13 to V14 and that will be only possible for OS 7.0 and + ?

Anyway, the script will make the job but we only have to wait 48h from the update to the installation.

 

Thanks a lot for your help.

 

Farid

  • 0
  • 0
Raymond Chan | posted this 29 March 2019

To be able to precisely control which firmware version get silently pushed to and installed on which Samsung devices under E-FOTA,  you need all of the following:

1. E-FOTA licenses purchased from Samsung or authorized reseller

2. your Samsung devices should be at least Android 7.0+ AND  support at least Samsung Knox v2.71

3. your MobiControl server has to be at least v14.1.5.

 

As I am not from Soti or Samsung,  and having any of the above items ready may incur extra cost for your company,  you are strongly advised to consult sales from Soti and Samsung to confirm the above information is accurate and up-to-date.

 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback