Enrollment error on DSE -> Access control exception ?

Enrollment error on DSE -> Access control exception ?

Hello,

we have a mobicontrol on version v 13.3.34 54 and of course we migrate (device are zebra TC75X android 7.1 Enroll type android +)

We have made a backup of the database of mobicontrol install it on a new server.

Actually, we made the upgrade on a test server with the version of mobicontrol  14.4.49

all port are open of course and 80% of my test are Ok.

This is the good new :).

 

But I don't know why but for some device ALWATS Zebra TC75X android 7.1 when i try to enroll it , i have an error message

I type the URL or enrollmentId in the client of mobicontrol (zebra TC75X) and I have an standard error -> contact your admin system ..

mobicontrol Client on device are on version 13 6 1476

 

In the log file of DSE I have this :

 

[2020-09-10 11:00:06.311] ERROR [General] (20): Unable to locate device with id '100002119'.  Mapping for device with id '8867948f33f105010019146522504865' is invalid and will be removed.

[2020-09-10 11:00:06.311] ERROR [General] (20):

 

*************************************************************************

* Exception: Device '8867948f33f105010019146522504865' does not exists. *

*************************************************************************

[AccessControlException: Device '8867948f33f105010019146522504865' does not exists.]

   at Soti.MobiControl.Controllers.DeviceController.GetDeviceByExternalId(String deviceId, Boolean loadDetails)

   at Soti.MobiControl.Api.Implementation.Com.DeviceConfigurationFacade.GetConfiguration(String deviceId)

 

I've try to factory reset device, reboot, but actually it's not possible to enroll 4 devices and i don't know why ..

 

Some people can tell me what's happen ?

thanks fpr your help

 

4 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 11 September 2020

Create a new add-devices rule on your migrated server, and use it to enrol your device again to see if you get the same error.

  • 0
  • 0
christopheBERNARD | posted this 14 September 2020

Hello raymond,

i've try but same error ...i can't understand ...

 

if you have any other idea don't hesitate ..

thanks

  • 0
  • 0
Raymond Chan | posted this 14 September 2020

Have you deleted the problematic devices before factory-resetting and re-enrollment back to your MobiControl server?

If so, and the problem still perssts, maybe the device entry in the database got corrupted in some way.   You can consider enabling the "Permanently delete devices from database when device deleted from Web Console"  option (the last option at the bottom) in your server "Global Settings -> Configure Archiving"  before deleting your device with your web-console and re-enrollment of the device.  Before you do that, you might need to perform SQL database back-up in case you need to fall back with the option disabled again.

 

 

 

 

 

 

  • 0
  • 0
christopheBERNARD | posted this 15 September 2020

Hello raymond,

I think i've find what happen ...already thanks for your time.

 

We migrate with the help of a consultant soti.

We have made a backUp of the database of production.

we restore the database on a enviroment of test , the consultant soti runs some sql script for to hide device.

 

I have enroll on the test environnement without problem but these device weren t in the production enviroment.

New device out of the box.

 

Afer one week or two week because i have some others task to do, i have delete some device on production and try to re enroll in the enviroment of test and of course i have this error because the device is already there.

 

If I look inside the table devInfo I can find the device ...

 

Do you know if I can just delete the entry in the table devInfo ?

 

I must to talk with the consultant soti on thrusday and CONFIRM this.

Thanks , and I will update this topic with some comment

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback