ET50 - Android - Enrollment Issue - SafetyNet Compliant

ET50 - Android - Enrollment Issue - SafetyNet Compliant

Hello- I have a device which is having a tough time getting enrolled into Soti MobiControl. When I create an add device rule, and try to enroll it, I receive an error that says "enrollment failed, this device is not SafetyNet Compliant. Please Contact your System Admin." Any Ideas on why this could be happening?

5 Answers

Order By:   Standard | Newest | Votes
Matt Dermody | posted this 03 May 2019

Is is at beta unit or engineering sample by any chance? I had the same issue yesterday with an engineering unit TC52. 

  • 0
  • 0
Jake, Jones | posted this 03 May 2019

No, it's a production unit. Here is the version that the device is on:

Android 6.0.1

Build Number: 03-21-20.00-MG-U01-STD

The unit seems to have the older version of the Soti Agent on there, not the newer looking icon (v13.3.0 Build 1059)

 

  • 0
  • 0
Matt Dermody | posted this 03 May 2019

Was it bootloader unlocked or rooted at any point? That's what ended up being the issue with my beta unit. 

  • 0
  • 0
Support Staff | posted this 06 May 2019

Hello Jake, 

 

Here is a link to information on what the "SafetyNet Compliance" is https://developer.android.com/training/safetynet

 

If you like, this can be bypassed VIA your rules "advance" section.   See image below for screenshot.

 

 

Hope this helps,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 1
  • 0
Matt Dermody | posted this 07 May 2019

Awesome! That did the trick on my TC52. 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback