Find device class name SQL

Find device class name SQL

Hello,

Is It possible to find what was name of enrollments rules deleted and associated by device class name (Rule Tag) in SQL Table ?

Thank you.

8 Answers

Order By:   Standard | Newest | Votes
RJMOD@SOTI | posted this 21 August 2019

Hello Rémi,

 

Thank you for requesting an answer from SOTI Support.

 

I would like to know what it is that you are trying to achieve with getting the name of the enrollment rules.

 

Regards,

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net

  • 0
  • 0
Rémi | posted this 21 August 2019

Hello,

I want to know what is the link between Class ID with the enrollement name because I have a lot of logs on my console : Unknown device class name (XXX) but this value XXX no longer exists on the rules.

Thank you.

  • 0
  • 0
AKMOD@SOTI | posted this 06 September 2019

Hi Rémi

 

Could you please share when do you get the error : 'Unknown device class name (XXX) but this value XXX no longer exists on the rules. ' on the console? And how often it is observed? 

 

Regards

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Raymond Chan | posted this 06 September 2019

Hi Remi,

What are the version and build numbers of your MobiControl server?  Have you made any upgrade(s) to your MobiControl server recently?

From which log file and how often do you get the error message you mentioned?  Are there any extra information on log entries that always appear before or after the error message you mentioned?

Have you ever modified the MobiControl database in MS SQL directly with MS SQL Management Studio or other tool/script?

  • 0
  • 0
Rémi | posted this 06 September 2019

Hello,

Our version is 13.4.0.5121
I think the messages appear from the beginning.
We have these messages several times per minute (about 4 times per minute more exactly)
I found in the DepRule table a RuleId that no longer exists in our console but is present in the SQL database that corresponds to one of the class name (TypeSpecific).
But I found only one. The other class names that appear in our console in error are not in the DepRule table.

Have a nice week end.

  • 0
  • 0
Raymond Chan | posted this 09 September 2019

It sounds very abnormal that you get such message four times per minute, and your log files must be very big.   Unfortunately, you haven't answered whether your database has been directly manipulated by any third-party tool/script or manually by any administrator.

 

If you can give details on lines above or below the error message in your log files, there might be clue on what went wrong.  Maybe you can send the log files directly to Soti support and open an official support ticket there so that cause(s) of your problem can be further investigated.

 

  • 0
  • 0
Rémi | posted this 26 September 2019


Hello,

I found a topic on this problem:
https://discussions.soti.net/thread/error-message-in-server-logs/?order=all#comment-1b9fcf63-ec3b-4484-a28c-a9a787bcbde6

I made this manipulation with some rule tag it worked except one that still displays very reccurrent error messages.

  • 0
  • 0
AKMOD@SOTI | posted this 27 September 2019

Hello Rémi,

 

Thanks for your response. We will update you soon on this query. Could you please let us know for the device type you created and deleted the rule?

Regards

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback