Geofence Alerts

Geofence Alerts

Hi all,

I'm having no luck in trying to get some geofence alerts to work, even just to test, and I'm wondering am I missing something.

I'm currently on the trial version of MobiControl Cloud, version

I'm testing with Lenovo TB-X304L tablets running Android 8.1.0, but have also been trying with a Samsung SM-G950F phone running Android 9.

I have created a geofence and created a corresponding left geofence alert rule, but it just doesn't generate any alerts, doesn't send an alert email, doesn't send a message to the device.

I'm putting a tick in the box that says 'Execute alert action even if this alert has been previously raised but not yet closed' when generating the rule.

I have a location data collection rule configured also, and it looks like that has been running OK when I look at location in the collected data tab.

I've done what I can to test things. I've taken a device outside the geofence and got it to check in, I've sent the device disconnect and connect scripts to see if that makes it realise where it is.

I have configured a second geofence in a completely different location and assigned the devices to that, and left the devices overnight to realise that they're not where I've said they're supposed to be. Still no alerts.

I've configured a different type of alert just to check (connecting to a particular wifi network) and the alert appears in the mobicontrol console, pops up on the phone and emails me just fine.

So, I suppose my questions are, am I missing anything stupid, and do geofence alerts normally work smoothly?



2 Answers

Order By:   Standard | Newest | Votes
BrianM | posted this 01 April 2019


Thanks for doing that checking, Raymond.

One of the SOTI Sales Engineers was helping me out with stuff, so I do have a guy who was looking in to things for me.

To update, since posting on Friday, I've had a few alerts through, so it's switched from 'not happening' to 'intermittent'. I'm not sure why.

I set up an 'entered geofence' rule and left the devices inside it over the weekend. The Samsung triggered the rule a couple of times over the weekend, on Friday afternoon and then Saturday night.

The Lenovo triggered it at different times on Friday afternoon, and then this morning. It appeared to trigger the rule when I switched the device from Admin mode to User mode. Hrm, and then again twenty minutes later when I tried the same thing, but that's not happening every time now.

The guy I'm dealing with has been good, I'll see what he comes back with.

  • 0
  • 0
Raymond Chan | posted this 31 March 2019

I repeated some previous geofence alert test procedure (used since v11.x) on my v14.3.0 MobiControl server in the last few days and encountered similar problem as yours.  From your description, I believe your test procedure and results are OK.  I'm just not sure which other patch version(s) of 14.x have this issue   Maybe you can open an official support ticket with Soti support team so that they can investigate the cause and the extent of the problem.

  • 0
  • 0

Give us your feedback
Give us your feedback