Has anyone experienced SQL Errors when updating to 15.3 - DACPAC: DAC Message: Warning SQL72015

Has anyone experienced SQL Errors when updating to 15.3 - DACPAC: DAC Message: Warning SQL72015

Just wondering if anyone has experienced SQL errors when upgrading from v14.3 to 15.3?

i get a bunch of these when trying to upgrade and it fails to update

 

2021-05-24 13:40:55.639: DACPAC: DAC Message: Warning SQL72015: The type for column Id in table [dbo].[Container] is currently INT IDENTITY (1, 1) NOT NULL but is being changed to TINYINT NOT NULL. Data loss could occur.
2021-05-24 13:40:55.654: DACPAC: DAC Message: Warning SQL72015: The type for column ContainerId in table [dbo].[DevContainerStatus] is currently INT NOT NULL but is being changed to TINYINT NOT NULL. Data loss could occur.
2021-05-24 13:40:55.654: DACPAC: DAC Message: Warning SQL72015: The type for column ContainerId in table [dbo].[DeviceConfigSectionStatus] is currently INT NOT NULL but is being changed to TINYINT NOT NULL. Data loss could occur.
2021-05-24 13:40:55.654: DACPAC: DAC Message: Warning SQL72015: The column [dbo].[DeviceInstalledApp].[AppleVPPLicenseId] is being dropped, data loss could occur.
2021-05-24 13:40:55.654: DACPAC: DAC Message: Warning SQL72015: The type for column ContainerId in table [dbo].[DeviceInstalledApp] is currently INT NOT NULL but is being changed to TINYINT NOT NULL. Data loss could occur.

2021-05-24 13:40:56.982: DACPAC: DAC Message: Message SQL0: An error occurred while the batch was being executed.
2021-05-24 13:40:56.982: DACPAC: Faulted [2]: Updating database
2021-05-24 13:40:56.982: DACPAC: DAC Message: Message SQL73036: Updating database (Failed)
2021-05-24 13:40:56.982: DACPAC: Faulted [2]: Deploying package to database
2021-05-24 13:40:56.998: DACPAC: Faulted [2]: Registering metadata for database
2021-05-24 13:40:57.015: DACPAC: FAILURE: DACPAC has failed to deploy: Microsoft.SqlServer.Dac.DacServicesException: Could not deploy package.
Warning SQL72015: The type for column Id in table [dbo].[Container] is currently INT IDENTITY (1, 1) NOT NULL but is being changed to TINYINT NOT NULL. Data loss could occur.

  • 24 May 2021
  • SOTI MobiControl
  • 4 Answers
  • 0 Upvote
  • 1 Follower
  • 864 Views
    • 4 Answers
    • 0 Upvote
    • 1 Follower

4 Answers

Order By:   Standard | Newest | Votes
Marcus Breitenthaler | posted this 25 May 2021

Hi Glen,

can you Try it 15.3.1 there are many Bug Fixes inside may also one for your Problem.

  • 0
  • 0
Glen | posted this 25 May 2021

Ahh should of put the whole thing. I trying to install version 15.31 build 1151.

I have contacted soti support and they are going to look into it as it is a database issue with fields having data in it and not being null.

 

  • 0
  • 0
Marcus Breitenthaler | posted this 27 May 2021

Hi Glen,

 

i have seen that Version 15.3.2 is now Available.

One may catch your Problem:

MCMR-26926 SOTI MobiControl upgrade from 15.3.0 to 15.3.1 failed due to database-related issues

  • 0
  • 0
Glen | posted this 14 June 2021

*update*

Thought ill give an update to this as it been a while. 

 

After working with Soti Support for a bit and sending them a copy of my DB for them to investigate.

They came back with "they do not support SQL 2019" and this is the reason why i cannot update.

 

Told me my options are, wait till the next version of MobiControl, no eta, as this will support sql 2019 or

move the Database to sql 2016, run the update, then move/copy it back to sql 2019 or

move to their cloud services as they maintain this so you dont have to worry about these sorts of things.....

 

tdlr - sql2019 not supported, wait still next version of mobicontrol for sql2019 support or move back to sql 2016 or move and purchase our cloud services 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback