How to Force Synhcronization of Google account to its currently binding company account

How to Force Synhcronization of Google account to its currently binding company account

A catalog rule has been created and assigned to a set of devices, which all of them has been enrolled by the same Add Rule.

It means , all of them has its binding to the same company binding.

The catalog rule holds some private application as mandatory.

Some devices assumes the new application immediately after the cycle request, but some take more then 3 days to receive it.

For those devices that are not installing the app, when clicks (in the device) on play store, it shows the application as not been released to the device. But it shows in the device MDM Catalog icone as Free and Mandatory.

 

It looks like the device has not synchronized its account to the company bindings.

After 3 or 4 days, it shows as released and may install.

 

I have tried to force google play protect to rescan and also to restart device, but it still has "its own time to synchronize".

Turning off the LockDown and set as administrative way, I got into device settings accounts, but the button to synchronize its android work account is disabled.

Is there a way to force the synchronization between device and its Google account ?

 

5 Answers

Order By:   Standard | Newest | Votes
Matt Dermody | posted this 14 June 2021

I am very curious about this as well. Are these delays the fault of MobiControl or is it the fault of Managed Play? I wish there was more logging and feedback in MobiControl to indicate where the source of the issue lies. I understand the update criteria that must be met for a device to actually install the apps from Managed Play (idle, charging, app not in foreground, etc), but this issue is more about the device showing eligibility for the app in the first place after it has been added to the App Catalog rule. Similarly, how can we be sure that changes to Managed Configurations of our pre-approved and previously deployed apps are actually being distributed from MobiControl?

  • 0
  • 0
RRMOD@SOTI | posted this 5 weeks ago

Hi Joao,

 

Thank you for requesting an answer from Support Staff. By default, apps are updated automatically when the following constraints are met: 

  • The device is connected to a Wi-Fi network.
  • The device is charging.
  • The device is idle (i.e. not actively used).
  • The app to be updated is not running in the foreground.
  • Google Play typically checks for app updates once a day, so it can take up to 24 hours for an app update to be added to the update queue. After an app is added to the queue, it will be automatically updated the next time the constraints above are met.

If the application is not getting installed / updated after meeting the above constraints, I would like you to create a support case(click here) or call SOTI Support team(click here) to seek assistance from one of SOTI Engineer, because we may need to look into the logs to see why the installation is not triggered after meeting the above constraints.

 

Also, if this post has helped you in solving your inquiry, I would request you to mark the particular comment as "is solution", so others may benefit from this information.

 

 

Kind Regards, Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Joao Nelson Cavezale de la Torre | posted this 5 weeks ago

Hi, the application is installed, but after long time after (2 or 3 days).

We have find out that turning the wi-fi off and let the connection flows by 4G, speeds the synchronization.

The wi-fi connection has no restriction as some devices on the same access point has different behavior among them.

A trick could be send by script a request to switch the wi-fi off, wait for some time and then switch it on again. Unfortunately, the scripts, with sleep in the middle of the wifi disable and enable commands, has not worked.

 

  • 0
  • 0
Ozan Acikalin | posted this 3 weeks ago

Hi,

i am maybe bit late but i had the same issue.

About the sync time between mobicontrol and google play services. When you add an new app to your managed google play
(MGP) account then the sync can take up to 24h. But when you already added an app to your MGP then the apps should
install right away.

But that was not often the case. So my solution was to send a "CheckIn" to my devices. Most of the time they noticed
the newly added apps from the application catalog.

But like you there were 1 or 2 devices who still ignored the availability of the apps. So i moved them to a folder where
the application catalog was not present and moved the devices back. Also like you said a reconnect helps too.

So every time when i add a new app to my catalog i send a CheckIn to my devices. I'm using this method since MCv15.1.

  • 0
  • 0
Joao Nelson Cavezale de la Torre | posted this 3 weeks ago

Hi Ozan.

I have tried your suggestion of moving to a none profile and then move back to the original one.

The issue stays the same, because the missing sync is not from MC to the device. In Fact it is from the device to PlayStore.

The solution was in fact to force connection by 3G.

For Samsung and Honeywell devices we have created an app to perform this connection redirection.

To Zebra we have not received allowance to develop yet.

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback