How to hide the "Settings" shortcut in lockdown mode?

How to hide the "Settings" shortcut in lockdown mode?

Hello SOTI-community,

we have several hundred Honeywell CT 60 devices which are running a self-developed app. I would like to use the lockdown mode (Android Plus) to only let the colleagues access this very app. Unfortunately, when we roll out updates, there are two settings-popups which the users will have to manually allow and set (battery optimization and system settings access), because they can't be set via script. Since that is the case, I have to have the Settings enabled in lockdown mode as well (or the device will deadlock itself, because its awaiting input (allowing of permissions) the user is not able to give).

Is it possible to have the settings enabled, but the shortcut hidden (so the users can't access the settings, but deal with the popups)?

Or is there an option to allow battery optimization and system settings access via script? (I have already opened a SOTI helpdesk ticket, but we couldn't manage to get it done)

Any help would be much appreciated.

BR

Dahin

4 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 19 May 2020

I do not have any Honeywell CT 60 nor your app to do any test.  However, the general approach to solve similar problem on other device is to find the activity name of Settings pop-up related to granting of required app permission, and have it included in the lockdown whitelist.  

  • 0
  • 0
Dahin | posted this 19 May 2020

Hello Raymond, thanks for responding.

Is there a compendium of permission popup activity names somewhere? (I suppose their activity names are always the same, throughout all the existing apps)

Edit: I have now figured out that you have to send the script "identify_activity" via SOTI MobiControl to the device and then check the log in MobiControl to get the result of that script (which is the top active activity on the device at the time of sending the script).

I enabled all of the ones I need, but now I have the problem that the lockdown screen will set itself active after 1 second -> I start the app via the shortcut -> app opens and the first permission popup shows (all that happens in a split second) -> lockdown screen becomes active (pops in the foreground and minimizes the app with the open permission popup)

How can I prevent that?

  • 0
  • 0
Raymond Chan | posted this 19 May 2020

If you use "identify_activity" to get the activity name, you of course should have the profile with the lockdown payload temporarily revoked in the course of your test.

 

I am not quite sure what you meant in your last post, and why the lockdown will become active right after you start your app.

  • 0
  • 0
Dahin | posted this 20 May 2020

Yes, of course. I forgot to mention that I put the test device in another device group, in which no lockdown was enforced.

What I mean is that when I start the app, the first permission setting pops up. If the app and a permission setting is open, the lockdown will minimize the app (I can still see it when I press the button to show all open windows). When I am fast enough, I can switch to the app and quickly tap "allow". I have succeeded in doing that for every popup. As soon as no popups are left, the app stays on top like it should.

Edit: I found a workaround - you have to enable the app you want to run and the settings app (in lockdown), but in the editing window of the app you want to run, you tick the checkbox "single app mode". This way the permission popups are not blocked (since the settings app is "enabled"), but you can never use the settings app because SOTI is forcing the other app to be open all the time.

For me this is not a good solution anymore, since I want to be able to offer multiple apps to our users (three at this time) for which they have to set the permissions, but I don't want them to be able to modify any settings. I am now looking in the SOTI scripting forum for a solution (new thread: https://discussions.soti.net/thread/allow-permissions-via-script/).

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback