HOW TO INCLUDE IN SURF WHITELIST URL FOR GOOGLE DOCS

HOW TO INCLUDE IN SURF WHITELIST URL FOR GOOGLE DOCS

I have created a whitelist for restrict which domains the user may access and it has worked pretty well.

But I could not include a entry for allowing the end user to be able to access a google form.

The url is:

https://docs.google.com/forms/d/e/1FAIpQLScM6-WlL2BIye_5INnlhmKAJ4_CqBQCCOtYwSoedq1ZuHnVME/viewform

I have tried different kind of entries, with no success as:

docs.google.com

docs.google.*

docs.google.com/forms/d/e/

docs.google.com/forms/d/e/1FAIpQLScM6-WlL2BIye_5INnlhmKAJ4_CqBQCCOtYwSoedq1ZuHnVME/viewform

What should I include on whitelist for allowing this url ?

  • 20 November 2020
  • SOTI surf
  • 5 Answers
  • 0 Upvote
  • 1 Follower
  • 458 Views
    • 5 Answers
    • 0 Upvote
    • 1 Follower

5 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 21 November 2020

The Website Whitelist/Blacklist filters and Exception fields in the "Website Filtering" option of Soti Surf profile payload seem to only support domain names, especially when wildcard character is used.  I've also found slightly different behaviours with different versions of Soti Surf.  If it is really true that you cannot set specific form in the exception field (which hopefully will get confirmed officially confirmed by Soti personnel in this forum in the very near future),  you might consider the following temporary workaround.

 

I don't know if you need to block everything from docs.google.com/forms except a few specific ones.  If you use home screen catalog plus kiosk mode that block arbitrary URL chosen by the end-user, you could consider just including the few exceptions without using Web-site Blacklist to block the whole docs.google.com domain.

  • 0
  • 0
Joao Nelson Cavezale de la Torre | posted this 21 November 2020

Hi Raymond.

I would like to open to any google doc.

I have set the link in catalog in order to avoid end user misstyping , but would not matter if end user try to access a different one.

The issue is it always alerts the end user as having no rights to access the any url of docs.google, including the one I have set in catalog(https://docs.google.com/forms/d/e/1FAIpQLScM6-WlL2BIye_5INnlhmKAJ4_CqBQCCOtYwSoedq1ZuHnVME/viewform)

Other opened domain worked fine as sysnobre.com.* ou enel.com.*

 

  • 0
  • 0
Raymond Chan | posted this 22 November 2020

Thanks for your clarifications. 

With your relaxed requirements compared to what I originally assumed,   I could successfully achieve what you want on my test server by:

 

1. Adding the following Whitelist item in "Configure Website Filtering" tab:

     docs.google.com

 

2. Adding the following catalog item in the "Configure Home Screen" tab: 

     http://docs.google.com/forms/d/e/1FAIpQLScM6-WlL2BIye_5INnlhmKAJ4_CqBQCCOtYwSoedq1ZuHnVME/viewform

 

Please note that I used "http" rather than "https" in the configuration of the second item above, but the URL actually used in Soti Surf secure browser will still be https://.

 

 

 

  • 0
  • 0
Joao Nelson Cavezale de la Torre | posted this 22 November 2020

Thank You Raymond.

In fact when google docs is up to open, it visit first accounts.google.com

I could solve the issue adding your suggestion and adding also accounts.google.com in whitelist.

  • 0
  • 0
Raymond Chan | posted this 22 November 2020

Hi Joao,

I did my test accessing a different form/doc in docs.google.com on a Samsung device running Android-Enterprise device agent in device-owner mode. The device only had the automated generated google account to access the managed Google Play store, and no additional Google account. There was no need to add accounts.google.com in the web-filter whitelist when accessing my test target doc/form.  I believe you need that in your case probably because of the access permission setting of the doc/form you are accessing.

 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback