How to move Elastic Search data\nodes to a different drive

How to move Elastic Search data\nodes to a different drive

The solution I manage runs in 2 server in MC14.4. One of them is just a DS and the other is DS+MS+DataBase+Elastic Search.

The server running MS+Elastic Search + Database is a windows 2012R2. Recently the upgrades from windows, that keep enlarging its cache patches, reach the system drive (C:) to critical space.

The initial MC installation has been followed the default installation, placing all bin files and elastic search in system drive (C).

I would like to move the elastic search data/nodes to other driver that has plenty of space available.

The recommendation I got from Soti is to use the setup file tool to install again only MS, because MS runs at the same drive as Elastic Search. Along the installation I would have to change the path to it.

The issue is it does not allow to change the path, because other MC components are already installed in system drive, as DS and even the current MS.

I believe I could uninstall everything but the database and install again to a different drive, having a risk to domains and certificate failures.

So, is there any parameter that we may set to Elastic Search create its data/nodes in a different path then the default? Maybe a environment variable or something in windows registry ? In positive way I could recreate the elastic search database in a different disk, releasing space to its normal growth.

 

  • 11 February 2021
  • SOTI MobiControl
  • 3 Answers
  • 0 Upvote
  • 1 Follower
  • 445 Views
    • 3 Answers
    • 0 Upvote
    • 1 Follower

3 Answers

Order By:   Standard | Newest | Votes
Joao Nelson Cavezale de la Torre | posted this 12 February 2021

I could find the solution, without reinstall.

It should follow this steps:

1) Stop DS+MS+Search

2)Copy the contents from folder c:\program files\SOTI\MobiControl\Search to the other disk folder (as example E:\MCElastic\Search)

3)Delete the content from folder data on the new folder (deltree E:\MCElastic\Search\data\nodes)

4)Edit the windows registry entry Options (\LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\mobicontrolsearch-service\Parameters\Java).

In the option content (BE CAREFULL TO SAVE ITS CONTENT IF SOMETHING GOES WRONG) replace the -Des.path.home=c:\program files\SOTI\MobiControl\Search by Des.path.home=E:\MCElastic\Search

It may makes sense to change the entry -Djava.io.tmpdir also, but then you need to create a different folder then used by data\node to keep the temporary files and point to it. 

In my case I have set is as -Djava.io.tmpdir=E:\MCElastic\temp

5) Start Search and check if a new folder named nodes has been created under your new folder E:\MCElastic\Search\data

In positive case you are good, otherwise I recommend you to rollback all actions.

6)Start MS 

7) Request in Servers the global settings, 

 
MobiControl Search Sync Interval
 

 to sync

Wait to finish, it will have something around 0 % of consistency. Then request to sync again to achieve 100%

8) Check to see your devices. If not being rollback everything.

9)Start the DS Server

  • 0
  • 0
Rafael | posted this 12 February 2021

A bit offtopic but i want to say it:

You don't have to write a header in capital letters. No reason to "scream" here and your questions won't be answered faster then. On your other post i thought it was a mistake (capslock) but now i know you did it intentional. It looks more like misbehaviour. 

So, please write in normal letters as all other do.

  • 0
  • 0
Joao Nelson Cavezale de la Torre | posted this 12 February 2021

Sorry. The capital letters was a browser replacing failure.

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback