iPhone App catalog webclip not updating

iPhone App catalog webclip not updating

We have a scenario where users will need to remove and reinstall an app on the iPhone. I was planning to use the app catalog webclip for this, however I am finding that the status of the apps does not update. For example, I have removed the app, but in the app catalog it still shows as installed and it's not possible to resinstall.

Is it possible to force a refresh of this on the device? Is there another way to achieve this? We would like to keep the phones locked down as much as possible.

I had hoped setting the app to mandatory would cause it to automatically reinstall after deletion but it doesn't seem to.

2 Answers

Order By:   Standard | Newest | Votes
Jake Ward | posted this 22 February 2021

This is something we are going to need working reliably for remote users so I wont be able to complete these steps each time. Is there a better way of doing this?

I tried adding a webclip which went directly to the URL on the download button which worked to trigger a download, however it then opens a webpage with an error as there is no content at the URL. Is there a way to do this to trigger the download but not open the blank page?

  • 0
  • 0
JSMOD@SOTI | posted this 18 February 2021

Hi Jake,

 

Thank you for posting on SOTI Central.

 

Please try to force a Check-in on the device then confirm on the device logs that it is able to complete 'MDM Check-in'. In my experience this has refreshed the webclip in the past.

 

Please also try to remove the app from the App Catalog Rule -> uninstall app -> re-assign mandatory app to the device.

 

Hope this helps.

 

Kind regards,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback