Lockdown screen is not configured

Lockdown screen is not configured


I have Samsung Android devices running Android 5.1.1 with the Android+ agent installed.

They were on MC 13.3.3 and have been migrated to MC 14.1.0 then 14.1.4.  We are on MobiControlCloud so have no access to the DB etc.

The agent on the device is which is showing as compliant and compatible.

I am moving the device from a group with a Lockdown profile into one without.   

When the device has moved into the non-lockdown group I get a white screen with "Lockdown screen is not configured" in the top right corner.

This has been done without incident numerous times in the past under 13.3.3 and 14.1.0.  I cannot be sure if it has ever worked on 14.1.4

I have even tried moving the device into a group without any polices at all -  same result  same message.

Putting it back into the group with the lockdown policy restores the regular lockdown screen.

Any devices that were in the non-lockdown group are working as expected.

Has anyone come across this before and do they have a solution?  Or am I looking at full device reset?




3 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 13 August 2018

Are the status of the profile containing the lockdown payload "installed" or "pending installed" soon after you've moved the device to the new device group?  Any other error/warning notification on your device?  

  • 0
  • 0
Eddie | posted this 14 August 2018

All profiles are either installed or, in the case of the Lockdown profile, uninstalled.

I tried it with a device in the office.  Same problem.  I did a hard reset, reinstalled MC, enrolling into the lockdown folder.  I moved it to the non-lockdown group and it worked as expected.

It points to an issue with devices that have had their agent upgraded.  But I have no evidence to back that statement up. 


  • 0
  • 0
Raymond Chan | posted this 14 August 2018

It's a bit confusing to get the full picture of your case based on your descriptions in the two posts.


In any case, after moving a device to a new device-group and something is not working, the first thing that needs to be checked is the status of EACH profile assigned to the device.  If the profile containing the lockdown menu payload can consistently get revoked and deployed to the device (based on the status report for the profile in the web-console), and a lockdown menu is not properly displayed,  then you can further narrow down possible cause(s), which may include:

- Incompatibility of device agent with firmware version/server version.

- Lockdown configuration has conflict(s) with settings from other profile payloads already deployed.

- System launcher improperly set or get stuck (e.g. device agent cannot make your lockdown to be the default launcher; or some application-run control/feature control policies create deadlock that disallow the system to use your defined lockdown as the launcher, etc.)

- Incorrect or unsupported features used in HTML/CSS  lockdown template.



In general, device agent needs to be fully compatible with the device firmware and with the MoibControl server.  Occasionally, some function may fail, especially but not always when there has been a major version upgrade on device-firmware or on MobiControl server version.


  • 0
  • 0

Give us your feedback
Give us your feedback