LockDown : browser short cut how to get the icon ?

LockDown : browser short cut how to get the icon ?

Hello all,

perhaps you can help me, i have a tablet under android.

On this tablet, we have a short cut with an url and a icon ...

 

The problem is, the user sometimes navigues into the settings of the device :( and change for example the wifi connection or anything else..

I would like to add a lockDown, it's enough easy ...and work fine.

 

My problem is, I would like to get the icon on this tablet (shortCut) but i can't find it ...

Where chrome store the shortcut icon on an android system ?

 

I've try to find with google but nothing find ...

 

Thanks for your help

21 Answers

Order By:   Standard | Newest | Votes
Raymond, Chan | posted this 22 November 2018

 The icon is embedded in the sandboxed directory of the app, and is not directly accessible by any file explorer in a non-rooted device.  While it is technically possible to get the icon when running the device in ADB mode, or extracting it from  asset directory of the apk file,  it might be illegal to use it due to copyright and licensing issues.   However, you don't need to find the icon path if you want to use its icon in MobiControl lockdown menu.

  • 0
  • 0
christopheBERNARD | posted this 26 November 2018

Hello Raymond,

thanks for your time and explain ...

Ok, I"ve made a print screen about the icon ...and cut the icon with a tool ..

Actually, all are happy about the final design :) Not so pretty of course but people can work with it ...

 

Just last thing, with this icon we open a link (intranet) but the url of the web browser are visible (chrome browser) ...

I've spend one day for try to hide this address bar BUT NOTHING WORK actually ...

I've try to hide the address bar with javascript by with window.open ...but nothing work ..

 

Any idea about how to hide the address bar on browser chrome ?

Or do you know a other browser where it's possible to hide this address bar ?

 

for to resume, now lock down it's ok, people who uses this tablet can't navigate to setting of the device ...

But when users click on icon, we open a browser link ...and the address bar is visible and users can modify this link :-( !

 

thanks

 

  • 0
  • 0
Raymond, Chan | posted this 26 November 2018

Why not use the Soti Surf secure browser to replace Chrome?  Soti is adding more and more security related features to it all the time.  You can hide the address bar, or you can configure kiosk mode to fix one or more predefined URL's for the end-user.  To use it in your lockdown menu item, you can either use launch://net.soti.suf  and add a single kiosk-mode item configured with Soti-Surf configuration payload in a profile, or use surf://your_target_URL  to directly start it browsing to your target URL.

 

 

  • 0
  • 0
christopheBERNARD | posted this 27 November 2018

Hello raymond,

Well, good idea ...but we need to update our version of mobicontrol and i think when we update the version of mobicontrol we install also soti surf ...

 

Thanks 

 

 

 

  • 0
  • 0
Ben Ragland | posted this 27 November 2018

You can get the SOTI Surf apk off of Play Store if you have it on your devices. If not, there are some sources online to find it, although I wish it was more accessible via SOTI directly. 

You also mention using window.open to launch the native browser in a "kiosk mode" but you were still seeing the address bar. I have actually used this same method and it was not displaying any exploitable features for me. The function I used was windows.open("http://google.com"); called by <a href="javascript:void(0)" onClick="openWin()>Google</a>. 

Hope this helps.

  • 1
  • 0
christopheBERNARD | posted this 28 November 2018

Hello all,

@ben => thanks for your time and sample

i've take your sample and in fact i've noticed with an url (www.domainName.xx) that's work !

The address bar is HIDE !

I used just a window.open WITHOUT parameters ...

 

but the url i try to open is rather than this :

https://10.xx.x.xx/ and so long ...

and when i used the same code the address bar is VISIBLE !!!!!!!

 

I can't understand why there is this difference with the same code !

Do you think , it's perhpas because the first url have a domain name and the other doesn't have ?

 

thanks for all

  • 0
  • 0
Daniel | posted this 28 November 2018

Hi Christophe or Ben,

 

could you provide us an Template-Example with your javascript version to hide the adressbar?

 

I'm very interested in, cause we're facing the same issue and Soti Surf is not an option at the moment in case of the "choose Browser" Menu with weblinks

 

Kind regards

  • 0
  • 0
christopheBERNARD | posted this 28 November 2018

Hello daniel,

just add into your html page the tag script

into the tag script , create for example a function called function openWin() { window.open("    URL    ");}

I don't know if you know the html , but on the body tag, add a link as this 

<a Href="javascript:void(0)" onClick="openWin();">CLICK HERE TO OPEN WEB PAGE</a>

 

for me that's work the URL bar is well hide into chrome browser but if my url is long or without a domain name the url is visible ...

i ' m completely lost with this problem ...

 

hope this help

  • 1
  • 0
Daniel | posted this 28 November 2018

@Christophe: Many Thanks. Unfortunately it's not working for me. When I click on the Link nothing happens. Can I ask you which Devices / Android Version you are using?

 

Kind regards

  • 0
  • 0
Daniel | posted this 28 November 2018

It's not an Solution but maybe a workaround: Could you not ask your Network-Department to set up a DNS CNAME for your Destination-Machine ? With this you could call a "real" URL instead of an IP-Adress-URL

  • 0
  • 0
christopheBERNARD | posted this 28 November 2018

i have a tablet Panasonic fz b2 with marsmallow inside but it's just an html page ...

 

when you said nothing happen, are you sure about the code, send me a private mail i will send you a complete sample

 

<script type="text/javascript">

function openWin()

{

    window.open(" YOUR URL ");

}

</script>

<body>

<input id="btnOpen" type="button" value="OPEN" onclick="openWin();" >

</body>

</html>

  • 1
  • 0
christopheBERNARD | posted this 28 November 2018

yes daniel, i can ask to put a domain name of this URL but before i would like to understand !

thanks

 

  • 0
  • 0
Daniel | posted this 28 November 2018

Hi Christophe,

Thank you. related to your issues I got stuck in the same behavior. A few websites are working, others don't. unfortunately my devices show nothing instead of chrome with adressbar :-( 

I've tested google, "long" internal URLs with https and without. only a few URLs working. Seems to be same behavior with the http:// and https:// commands within the Soti Kiosk-Configuration. 

 

 

  • 0
  • 0
christopheBERNARD | posted this 28 November 2018

i'm lost, i"ve try many mobile browser ...but everytime the url is VISIBLE ...

if you have any other idea ...don't hesitate 

 

  • 0
  • 0
Raymond, Chan | posted this 29 November 2018

Hi Christophe,

If your devices are using Android Enterprise device agent,  you have an additional option of using Chrome browser with some managed configuration.  You can configure your required URL whitelist using the App Configuration parameters defined in your App-Catalog rule.  Although the URL is still visible,  the device end-user cannot use the address bar to input and browse any URL other than those allowed in the URL whitelist.  Besides, you have 70+ other parameters you can configure.

 

 

  • 1
  • 0
Daniel | posted this 29 November 2018

Hi Christophe,

 

I've done a few tests and for me it seems that Android Webview has a few problems with https / SSL Sites. I got these Errormessage: soti    : [KioskActivity$KioskWebViewClient][onReceivedSslError] Got SSL error:primary error: 3 certificate: Issued to:.... I don't know if you also want to open a https Site...

After a few Minutes in the Internet it seems that the Android Webview has a few problems with ssl encrypted website. For my testing, official https Sites like Google are working, also internal Website without SSL. Internal SSL Websites don't. The certificates needed are installed on the device and when I open such a link with Chrome everything looks good and the encryption is also "green" Anyway I updated my device to the newest OS without any success. BTW: I get the same Error when I use http:// or https:// within the Lockdown Menu. 

For me the best solution would be Soti Surf, so I can decide within the lockdown if a website should be display in Soti Surf (fullsreen mode) or in Chrome. Unfortunately after Soti Surf is installed you will receive the "choose Browser" Menü and till now, I don't have a clue to avoid the Message or set the default Browser by Script / intent / ...

 

  • 0
  • 0
christopheBERNARD | posted this 29 November 2018

Hi all,

@raymond=> thanks for your time , but i don't find the screen you mentionned => add edit catalog rule ...

where is it ?

 

thanks 

  • 0
  • 0
christopheBERNARD | posted this 29 November 2018

Hello daniel, 

sorry after post my last answer i've read your topic :)

well, thanks for information yes i need to use an https and hide the address bar ...

 

I'm a beginner with soti mobicontrol , and this morning i've find in the profil => SOTI SURF / SOTI HUB

Ohhh my god perhpas it's install since the begining ...sorry i used mobicontrol since few month and not every day.

 

Well, i have create a profile add my url and assign the profile to my device (tabket Panasonic FZ B2 android 6.0)

Nothing happens ...ok i read the doc of soti and see i need to install the apk of soti surf on the device ... ok

I've done ...apk is install on device

 

I restart the tablet, if i launch the soti surf the web site is well open with ADDRESS BAR HIDE =>  but i can close the soti surf browser and navigate to the settings of the tablet ...

 

Something is not clear for me ...

I need to add a lock down with soti surf ?

 

thanks

  • 0
  • 0
Raymond, Chan | posted this 29 November 2018

You need to add "Chrome browser" from Managed-Google-Play store (hence only supported for Android-Enterprise devices) rather than from normal Google-Play store in your App-Catalog rule.  Then, in the "advanced" option for this "Chrome browser" app item, you can find what I showed in my screenshot.

Your MobiControl server should be at least recent releases of v13.4.

  • 0
  • 0
Daniel | posted this 29 November 2018

Hi Christophe,

That should be easy ;-) Make sure Soti Surf is installed on the device. You can download the newest Version from Soti Download. Create a Profile that sets Soti Surf to Kioskmode:

 

Now you can Setup the Soti Lockdown / Kioskmode like this:

And add an entry for your kiosk mode. Make sure your URL starts with surf:// our surfs:// instead of http:// or https://

 

 

Safe and assign and everything should work. Take Attention: for the use of Kiosk-Mode you have to set up Administrator Authentication und Profile -> Security -> Authentication

  • 0
  • 0
christopheBERNARD | posted this 29 November 2018

Hello all

problem is solve i have create a profile, add lock down, authentification for lock down => why it's not on the screen when your create a lockdown ?

 

After, add soti surf click enable kiosk mode

 

add in menu item inside lock down => surfs://URL

assign to the tablet ...

 

that work, when i click on the link inside the lock down soti surf is well open WITHOUT ANY ADDRESS BAR...

THANKS A LOT FOR HELP

  • 1
  • 0

Give us your feedback
Give us your feedback
Feedback