Lockdown Windows Desktop Classic

Lockdown Windows Desktop Classic

Hello,

i would like to run command prompt with special arguments cause i need the user to run a batch-file.

Direct linking the batch file in the kiosk just offers the user to save or start the batch, but i want it to execute directly.

Packaging the batch as executable isnt working either.

 

In the Help Section there is info on giving parameter to an executable:

 

 So my resolution was to run batch via this linked in the lockdown:

C:\Windows\SysWOW64\cmd.exe,/c "c:\batch.bat"

But it just opens command prompt.

 

Does anyone has a bit of experience with the windows lockdown?

Kind Regards John

4 Answers

Order By:   Standard | Newest | Votes
SCMOD@SOTI | posted this 28 October 2019

Hey John,

 

Thank you for your question.

Can you confirm that the batch file doesn't need Command Prompt to be open as Administrator. 

In addition to above, the user account should have privileges to run the file on the device.

 

Thank you. 

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
John Doe | posted this 29 October 2019

Hello SCMOD,

yes the batch can be run without administrator rights by the user.

I guess its just the problem that /C isnt really a parameter unlike -t or something.

Just linking the batch is giving the option to download or to run the batch file, would be nice if this would behave differently.

Kind Regards John

  • 0
  • 0
Rob Brunink | posted this 4 weeks ago

I'm also having a similar problem where I use this command to open up websites in a kiosk mode and it works if you strip the https:// from the link. We have one system where it won't resolve the address without the https://. If I add the https:// then the app that controls the kiosk screen will try to open the page and the page is not compatible with the IE engine that the kiosk screen uses. 

msedge.exe --kiosk --edge-kiosk-type=public-browsing --kiosk-idle-timeout-minutes=2 Internalwebpage.com

That is the command added to the lockdown setting. I left out our address for security sake and replaced it with "internalwebpage.com"

I created a batch file that has the command 

start msedge.exe --kiosk --edge-kiosk-type=public-browsing --kiosk-idle-timeout-minutes=2 Internalwebpage.com and that works but I get the File Download - Security Warning and have the option to run, save or cancel. It works if I select run. Is there a way to get rid of the prompt?

I tried like several ways and none of them worked. We are running Windows 10 20H2 and using MobiControl 15.4 and the latest agent.

  • 0
  • 0
John Doe | posted this 4 weeks ago

I did not get this to work the way i wanted.

Ive created myself a workaround to run batch files over mobicontrol with a planned task running a specific script name at startup. If you want to run something you copy your batchfile on the device and after reboot it gets run and deleted afterwards.

I dont recommend this for any devices at risk because it could be exploited if any 3rd party would be able to place files with the right file and directory name on the device.

Kind Regards John

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback