MDM ELM client is going in sleep mode ??

MDM ELM client is going in sleep mode ??

Dear Team ,

 

we are using Samsung elm agent for our devices with android 7.1 . but if device is in admin mode . agent is getting disconnected . we have to connect in manually or reboot the device to make it online .

please suggest

15 Answers

Order By:   Standard | Newest | Votes
Raymond, Chan | posted this 20 September 2018

Try again after sending the script command

   elm_awaken 1

to your Samsung ELM Android+ device agent.

 

  • 0
  • 0
Eddie | posted this 26 September 2018

Anil

Did Raymond's solution work?

I'm having devices only come online for a while then show as offline on MobiControl.  Opening the client on the device brings it back online but we need to be able to see the device is online and potentially track if they report an incident.

Eddie

  • 0
  • 0
Raymond, Chan | posted this 27 September 2018

Hi Eddie,

 

I assume your device is running a Samsung ELM Android+ device agent.  

Did you time the time interval between getting your device agent out of the foreground and  your device icon marked as offline in your web-console?     

Also, what value did you set for the "locate timeout" in your  All-Platforms->Servers tab?

Finally, did you turn on any built-in power-saving mode in Settings, or have any app that turns off your Wifi/Cellular automatically for aggressive power-saving?

 

  • 0
  • 0
Support Staff | posted this 27 September 2018

Hi Anil, 

 

Another way you may be able to improve this is to set the MobiControl application on the devices in the foreground.

 

You can send it to devices/groups using the scripting tool in the MC console. I have copied an excerpt from the scripts section for you.  

 

foregroundmode Switches the MobiControl service between foreground and background modes. While running in foreground mode the MobiControl process receives high priority and is not killed by the system.

While the service is running in foreground mode, a MobiControl icon is displayed in the notification area of the device.

foregroundmode enable|disable

Example

To enable foregroundmode

foreground enable   

 

Hope this helps!

 

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Eddie | posted this 28 September 2018

Hi Raymond

Thanks for getting back to me on this hijacked thread.

You assume correct - Samsung ELM Android+.  Running Android 7.  Devices running Android 5.1.1 have the same agent and do not have this issue.

The time interval between putting into the background and dropping off - I will check and get back to you.  For the record these devices have a lockdown screen.  

Locate Timeout is 45 seconds - that's how it was out of the box.  I've never touched it.

There should be no power saving modes enabled.  We require always on comms and I know the devices are communicating, they're just showing as offline on MobiControl

Eddie

  • 0
  • 0
Raymond, Chan | posted this 28 September 2018

Hi Eddie,

 

When you said your devices have a lockdown screen, did you mean MobiControl lockdown-menu/kiosk mode ? or just  Lockscreen after inactivity timeout configured in device's Settings ?

 

 

I remember I did have some Samsung devices with similar problem a few months ago.   Yesterday, I did a test on a Samsung S8 running Android 8 and  there was no such problem.  The device agent version was 13.5.1.1044.

What is your Samsung device agent version?

 

 

I'll wait for your measurement result about the time interval I mentioned in my last post.  Please don't forget to verify whether your device is really on-line (e.g. can browse some external site) when your MobiControl web-console icon shows that the device is offline.  The picture should be clearer after such measurement.  

 

  • 0
  • 0
Eddie | posted this 28 September 2018

Yes, MobiControl lockdown/kiosk mode.

Have just built a tablet to same spec as field. so watching and waiting.

  • 0
  • 0
Anil | posted this 30 September 2018

Dear Eddie/Ramon,

 

i have send the script from roman and for me its working fine . support staff also suggest some command(foregroundmode enable|disable) in bellow post i will try thta also and let you know the result .

 

  • 0
  • 0
Anil | posted this 30 September 2018

Dear Eddie/Ramon,

 

i have send the script from roman and for me its working fine . support staff also suggest some command(foregroundmode enable|disable) in bellow post i will try thta also and let you know the result .

 

  • 0
  • 1
Eddie | posted this 01 October 2018

Hi Raymond

 

Apologies for the delay.  The tablet I'm using here is dropping out after 4 to 8 minutes.  Reopening the agent on the device reconnects.  

This test was performed 5 times.  the device was not on charge but was at circa 80%

Three were done by logging into device, opening the MobiControl app to establish a connection. I then opened another app and left it there.  After 4 to 8 minutes the device disconnected from MobiControl.  Opening the app again re-established connection and the test was repeated.

Test 1 3:49

Test 2 4:31

Test 3 6:29

The next two tests were done by opening the MobiControl app, connecting and leaving it running.  Between 4 and 5 I connected by pressing Agent Status

Test 4  3:53

Test 5 4:48

Finally I connected the device and sent the command foregroundmode enable down via "Send Script".  At time of writing it has remained online for an hour and going strong.

 

  • 0
  • 0
Eddie | posted this 01 October 2018

Hi Anil

I've tried foregroundmode enable this morning and it works.  I've now set up a file sync rule that only contains that command which runs at device login.

My console is now filling up with devices that have come online and now remain online. 106 0ut of 196 now online and remaining online so far.  Compared to an average of 7 out of 196 before adding the rule

  • 0
  • 0
Edgar Gomez | posted this 01 October 2018

Hi

If you disable Doze mode in a feature control profile it could prevent OS to kill Mobicontrol for inactivity. This happens in android 7 and 8.

 

 

  • 0
  • 0
Anil | posted this 02 October 2018

this Option is not available in my MDM 13.4.0.4822

  • 0
  • 0
Eddie | posted this 02 October 2018

Mine neither - v14.1.  The foreground mode works though.

  • 0
  • 0
Raymond, Chan | posted this 02 October 2018

Hi Eddie,

It's nice to hear that you find the solution using "foregroundmode enable " works for you.  As long as you don't mind a notification saying "MobiControl is running" always present on your device notification bar at the top,  it is the oldest approach to keep any MobiControl Android device agent (i.e., not just Samsung ELM) from being killed/forced to sleep.

 

The script "elm_awaken 1" might work only for some Samsung Android 6.0+ and Knox 5.7+ device running some v13+ Samsung ELM device agents.

 

 

 

Disabling Doze mode with Feature Control configuration in a profile is usually the last option to try because such efficient power saving mode is not allowed for MobiControl device agent as well as any other apps that might have big impact on battery life.  

 

To me, finding the root cause why the agent gets killed/inactive and check any possibility to remove the cause often provides the best solution.    If you have enabled some ow-power mode and/or lockscreen timeout of 5/10 minutes, then your test results of 4 to 8 minutes delay might suggest the problem stems from such settings. 

 

I tested a few Samsung Android 7/8 devices in the last two days, and each has a different best solution from the above choices to solve this same problem.

 

  • 1
  • 0

Give us your feedback
Give us your feedback
Feedback