Mobicontrol Agents not starting anymore - defective SQL Database on Client most likely

Mobicontrol Agents not starting anymore - defective SQL Database on Client most likely

Hello dear Soti Team,

We are currently experiencing some problems with some Android 9 (Android Plus) Honeywell CT60s. We noticed that many devices are displayed as offline in the web view. We then noticed that the Mobicontrol Agent can no longer be opened on the devices and that the agent takes up the entire memory space of the device (15GB). The device can therefore no longer be administered.

I read in the forum that this could be a bug in the SQL database on the device:
https://discussions.soti.net/kb/android-enterprise-and-oem-specific-agents-are-crashing-after-agent-upgrade/

Agent 14.3.4.1006 is currently installed on all affected devices.
It is possible to copy a new agent via USB and install it over the device. I was able to install the following version: HoneywellMobiControl1442NewGen_1039.
However, the problem persists, presumably because the defective and cluttered SQL database is still present in the background.

Unfortunately, we have the feature control with "Disable removal of Mobicontrol Agent" active, which is why we are unable to completely remove the agent beforehand.

Is there any way we can remove the complete Mobicontrol Agent installation in order to start a fresh installation of the agent? Unfortunately, Mobicontrol is still functional enough to prevent us from uninstalling it.

It would be very bad for us if we now have to reinstall devices worldwide.

 

Cheers

Maik

11 Answers

Order By:   Standard | Newest | Votes
JCMOD@SOTI | posted this 15 January 2021

Hi Maik,

 

Thank you for posting in SOTI Central.

 

On an affected device, can you check /data/data/net.soti.mobicontrol.honeywell/ and see what folder is using up the storage? We had an issue previously where the /enterprise/usr folder in specific conditions would fill the storage (might not be present in Honeywell devices). We fixed that on agent startup in 14.3.4.1005 and introduced a script called clearenterprise which cleans that folder since 14.1.7.1034.

 

Ideally, with this type of issue, I recommend you raise a Support Case and we can expedite the investigation. You can do so through support@soti.net / support.eu@soti.net. However, I'm happy to contribute here with you as a secondary option.

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
MaikStrassmann | posted this 15 January 2021

Hey,

thanks for the fast answer!

Both in File Explorer on the unit and via USB on the computer, I only see the folder structure, but completely without files. Independent of the Honeywell folder as well as all others.

Looks like all Files are hidden or something.

Dieser PC\CT60\Interner gemeinsamer Speicher\Android\data\net.soti.mobicontrol.honeywell\files\PdbPkg

Dieser PC\CT60\IPSM card\Android\data\net.soti.mobicontrol.honeywell\files\PdbPkg

 

 

  • 0
  • 0
JCMOD@SOTI | posted this 15 January 2021

Hi Maik,

 

On an affected device, are you able to clean up any free storage space and then run the script I mentioned after starting the MobiControl agent?

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
MaikStrassmann | posted this 15 January 2021

I still have ~2GB of storage space and I could also free up 1-2 GB on each device, that's not the problem.

How should I execute the script via Mobicontrol if the agent does not start and therefore the communication via the web interface does not work?

Or is there a way to output a script locally on the device?

Cheers

Maik

  • 0
  • 0
JCMOD@SOTI | posted this 15 January 2021

Hi Maik,

 

My presumption was if you could clean the storage to allow the MobiControl Agent to run. Then you could send the script to the device once it's back up and running. Then observe if the storage remaining decreases. It'll also give us an opportunity to obtain logs.

 

Can you clarify, after you do this the agent still doesn't start and that is why you advised the SQL is the problem perhaps as detailed in your original post?

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
MaikStrassmann | posted this 15 January 2021

thats all we´ve got with the agent

  • 0
  • 0
JCMOD@SOTI | posted this 15 January 2021

If you navigate to Settings -> Apps -> MobiControl -> Storage. What do you see? If the Cache is the problem, you should see a Clear Cache button.

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
MaikStrassmann | posted this 15 January 2021

App-Size: 59mb

User-Data: 14.53GB

Cache: 94 KB

TOtal: 14,59GB

  • 0
  • 0
Raymond Chan | posted this 16 January 2021

Hi  MaikStrassmann,

Haven't you already said that there are  ~2GB of storage space and you can  free up 1-2 GB?.  Memory space is thus not an issue any more.  Don't waste time on that direction.

 

How many devices are running the problematic device agent v14.3.4.1006?  Is there any device running this device agent version and has no problem?

 

What was the stable device agent version previously used on the devices that are currently problematic?

 

What are the version and build numbers of your MobiControl server?

 

.

  • 0
  • 0
MaikStrassmann | posted this 18 January 2021

 

How many devices are running the problematic device agent v14.3.4.1006? - ~25 devices all around the world

Is there any device running this device agent version and has no problem? - for the last 5 days: no - for today: 2 devices

 

What was the stable device agent version previously used on the devices that are currently problematic? I'm not sure to be honest, thats part of our IT department.

 

What are the version and build numbers of your MobiControl server? Version: 14.5.4.1035 

 

The strange thing, today 2 of those agents with that version are online again..

We really dont unterstand all this behaviour

  • 0
  • 0
Raymond Chan | posted this 18 January 2021

Hi Maik,

 

Have you been able to download the device log file from the two devices that can get connected to the server earlier today?  If so, check  (especially warning/error) entries related to connections in the last 2-3 days, with special attention to lines for the time just before the device getting connected again today. 

 

Can you deploy and revoke any new test profile successfully to these 2 devices now?

 

Is your MobiControl server an on-premises server or a cloud instance?  Has it been upgraded recently?   

 

Is there any particular reason (bug fix, new feature, etc.? ) for upgrading the device agent?   Have you done any thorough test on the stability/compatibility of the new device agent on a test device on-hand before deploying to other devices worldwide?  

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback