MobiControl Search service can't start with OpenJDK11

MobiControl Search service can't start with OpenJDK11

hi everybody,

we run MobiControl version 14.2.2 amd we've been asked to replace Oracle Java runtime with OpenJDK. In one test environment where I could test this migration with SOTI 15 I had no problems, but unfortunately on prod environments it is still not possible to upgrade the MobiControl version due to a not possible outage.

Unfortunately it looks like everything goes smooth apart from the MCSearch service which, when OpenJDK is in place, cannot start.

I am trying with OpenJDK version 11:

C:\Windows\system32>java -version
openjdk version "11" 2018-09-25
OpenJDK Runtime Environment 18.9 (build 11+28)
OpenJDK 64-Bit Server VM 18.9 (build 11+28, mixed mode)

I did following actions:

- extracted the zip file under D drive with folder named jdk-11

- stopped MCSearch service

- uninstalled Oracle java runtime

- rebooted server (Win2016)

- created env variables JAVA_HOME and MC_JAVA_HOME with value D:\jdk-11

- edited PATH env variable to add D:\jdk-11\bin and %JAVA_HOME%\bin

- created reg keys

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft]

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment]
"CurrentVersion"="1.8"

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.8]
"JavaHome"="D:\\jdk-11"
"RuntimeLib"="D:\\jdk-11\\bin\\server\\jvm.dll"

 

When trying to start MCSearch through the Windows services window I receive error stating that it is not able to start with error code 4. If I look in the logs in fact, it looks like the problem is that "it cannot find the file specified".

The event viewer instead just tells: "The MobiControl Search service terminated with the following service-specific error: The system cannot open the file."

I also tried to uninstall MobiControl and reinstall it, but no luck.

Of course, reinstalling the Oracle java runtime, everything restarts to work pretty fine.

Could please someone help me to understand what I'm doing wrong?

 

Thanks a lot for your hekp in advance and best regards

2 Answers

Order By:   Standard | Newest | Votes
JSMOD@SOTI | posted this 18 January 2021

Hello,

 

Thank you for posting on SOTI Central.

 

Have you tried following our article on OpenJDK on this configuration? - Using MobiControl with OpenJDK instead of Java (soti.net). OpenJDK11 should work on "MobiControl 14.3.0 and higher", so I would suggest upgrading your environment first.

 

Failing this, the "cannot find the file" error could be referencing an old Java file path from a previous installation, so I would suggest revisiting the article above, double-checking your configuration, and removing all traces of Runtime before trying again.

 

 

Kind regards,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
JSMOD@SOTI | posted this 29 January 2021

Hello,

 

How did you get on with this? I kindly ask that you mark the appropriate comment as 'Solution' or share your workaround to help others find the answer. 

 

Looking forward to hearing from you.

 

Kind regards,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback