.NET Core error when trying to install on new server

.NET Core error when trying to install on new server

Just got a new server build with Windows Server 2016 and trying to install Soti Mobicontrol. But get .NET Core error even thus is has been installed. 

 

any idea how to fix this?

 

6 Answers

Order By:   Standard | Newest | Votes
JCMOD@SOTI | posted this 07 January 2021

Hi HelVan,

 

Thank you for posting in SOTI Central.

 

Rather than install .NET Core SDK, try .NET Core Runtime instead. Make sure to uninstall the SDK first too. You can download it via:

https://dotnet.microsoft.com/download/dotnet-core/thank-you/runtime-desktop-3.1.10-windows-x64-installer

 

Also, ensure you're using .NET Framework 4.8 via https://dotnet.microsoft.com/download/dotnet-framework/thank-you/net48-web-installer.

 

Please mark this post as the solution if it resolves the installation problem. Also, feel free to reach out if you have any questions or need clarification.

 

Source: https://www.soti.net/mc/help/v15.2/en/setup/installing/system_requirements.html

 

Regards,

Technical Support | SOTI Inc. |1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
HelVan | posted this 12 January 2021

still the same error :(   

uninstalled all .NET installations and choose the two you linked in the response. .NET framework allready installed as feature on the server.

  • 0
  • 0
Raymond Chan | posted this 12 January 2021

Have you installed all patches for your Windows Server 2016?

  • 0
  • 0
HelVan | posted this 15 January 2021

Problem solved. I uninstalled .NET CORE 3.1.1 and installed 3.1.8. That solved the problem.

 

thanks for the replies :)

  • 0
  • 0
Raymond Chan | posted this 16 January 2021

I don't know why you did not install v3.1.10 that was recommended by a moderator in an earlier post, but instead installed v3.1.8.  Did you find any problem with the former? If so, can you please share the details?

 

BTW,  I myself have been using v3.1.8 in the recent few months in my professional services projects for all my governmental customers.  

  • 0
  • 0
Ugur Kosa | posted this 03 February 2021

Hi,

I have same error and I tried your way but it not working. Could you please give more detail?

Regards

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback