Open Chrome without Address Bar

Open Chrome without Address Bar

Hi,

 

Can anyone advise how I get the page to display correctly AND with no address bar

 

Chrome v76.0.3809.132

MobiControl v14.3.4.1087

Hardware Honeywell Android 8.1.0, build 86.00.13-(0108)

 

Using https://myurl#Intent;scheme=http;action=android.intent.action.VIEW;component=com.android.chrome/

I get no address bar BUT the page has zoomed in:

So, I tried browsers://myurl#Intent;scheme=http;action=android.intent.action.VIEW;component=com.android.chrome/

I now get the address bar, but the page displays as I want it to.

Tried using intent:https://myurl#Intent;scheme=http;action=android.intent.action.VIEW;component=com.android.chrome/ out of curiosity, but the button on the kiosk page doesn’t do anything when pressed.

 

Thanks in advance

Bhav

6 Answers

Order By:   Standard | Newest | Votes
Raymond, Chan | posted this 26 September 2019

Even though Chrome support many managed configuration options on Android Enterprise platform, there doesn't seem to have any option that disable address bar.  So until that feature is implemented by Google developers in future Chrome releases, your better option is probably to consider using other browsers that support this feature.  Soti Surf secure browser is definitely one that you can consider.

 

  • 0
  • 0
Bhav | posted this 27 September 2019

Thanks for your response Raymond.

Have gone down the Surf path and have hit a snag with it.

I have added Launch://net.soti.surf as a lockdown item via profile

I have created a different profile for Surf settings. I need to enable home page, as EACH device requires a different URL i.e. https://myurl=HHxx where xx is a 2 digit number)

My problem is that when I select icon on the kiosk page, nothing happens. If I exit kiosk mode, I can launch Surf and browse to the URL. But I can't via the kiosk?? It was working for a while, but then nothing (I did add the WMS logo to the server and assign to the lockdown item - cant be that, can it?)

  • 0
  • 0
Raymond, Chan | posted this 27 September 2019

What are the active MDM API's reported on the configuration tab of your device agent?   And the version and build number of your device agent and Soti Surf?

 

You need to make sure 

1. you have deployed authentication payload with "device administrator password" configured

2. the status of both profiles containing the kiosk and Soti Surf payloads are "installed"

  • 0
  • 0
Bhav | posted this 27 September 2019

Hi Raymond, see below

 

What are the active MDM API's reported on the configuration tab of your device agent? [Bhav] I dont see where to get this info? Is this what you're after?

And the version and build number of your device agent and Soti Surf? [Bhav] Agent = 13.9.0.1046, Surf = 14.4.3.3

 

You need to make sure 

1. you have deployed authentication payload with "device administrator password" configured

   [Bhav] Yes, done

   

2. the status of both profiles containing the kiosk and Soti Surf payloads are "installed"

[Bhav] Everything showing as installed

  • 0
  • 0
Bhav | posted this 27 September 2019

Well, I feel silly!

I figured out why I couldn't get the icon to work. I forgot that in the template, I had changed the MCLink0 value to a custom value previously <insert facepalm>.

I just need to test Surf to see if it will do everything I need it to now.

 

Thank You Raymond for your quick and helpful responses, Greatly appreciated!

  • 0
  • 0
Raymond, Chan | posted this 27 September 2019

You are welcome.

 

You can try the kiosk mode in Soti Surf to have its address bar removed.  

 

Please note that if you want the existing Soti Surf session to persist while going back and fro between different MobiControl kiosk items, you might need to use launchalways:// instead of launch://.

  • 1
  • 0

Give us your feedback
Give us your feedback
Feedback