Ping/Beep MC93 from SOTI

Ping/Beep MC93 from SOTI

Is there a script (or other method) I can send to a device to have it beep or make some sort of noise? We're trying to implement some steps to find devices that employees "hide" in the warehouse.

Devices are all MC930B and MC930B

Cloud Mobicontrol v15.2.6.1006

Android v8.1

SOTI Agent v14.4.6.1001

7 Answers

Order By:   Standard | Newest | Votes
ANKMOD@SOTI | posted this 18 June 2021

Hello Joe,

Greetings

Thanks for requesting an answer from Soti !! 

For testing this issue , You can  try to send  any mp3 file(for example here findme.mp3) on device and try to use send intent script following that.

sendintent -a "intent:file:///sdcard/download/findme.mp3#Intent;type=audio;component=com.android.music;end"

 

Also, if this post has helped you in solving your inquiry, I would request you to mark the particular comment as "is solution", so others may benefit from this information.

 Regards

Technical Support | SOTI Inc. |+1-888-494-SOTI (7684) | support@soti.net | www.soti.net |

  • 1
  • 0
Matt Dermody | posted this 19 June 2021

You can also try using this script which will show a message and play an audible beep. 

 

showmessagebox "Your message" NO_TIMER 1 NOTIFY_DEVICE

 

 

Note that warehouses are loud and large so you probably won't have much luck hearing the this noise unless you happen to be very close to the device. 

  • 0
  • 0
Joe | posted this 21 June 2021

This script works when not in lockdown mode. When in lockdown mode in SOTI Surf, it displays the message but does not beep. I've checked all my profile settings and don't see anything that would stop the sound from playing when in lockdown in Surf. Any ideas?

 

I have GPS location turned on for these devices too, so we'll theoretically be able to get close enough to hear the device if we keep making it make a noise.

  • 0
  • 0
Joe | posted this 21 June 2021

Same results as below. This script works when not in lockdown mode. When in lockdown mode in SOTI Surf, it displays the message but does not beep. I've checked all my profile settings and don't see anything that would stop the sound from playing when in lockdown in Surf. Any ideas?

  • 0
  • 0
Shawn T | posted this 22 June 2021

Try the remote ring feature introduced in agent version 14.4.5

ring_device 90 10 1

; ring_device
; ring_device <volume>
; ring_device <volume> <time>
; ring_device <volume> <time> <is Vibrate>

; 1. When we send ring_device, it will ring the device with the default ringtone volume for 60 seconds.
; 2. When we send ring_device 40, it will ring the device with 40% of the max ringtone volume for 60 seconds.
; 3. When we send ring_device 40 10, it will ring the device with 40% of the max ringtone volume for 10 seconds.
; 4. When we send ring_device 40 10 1, it will ring and vibrate the device with 40% of the max ringtone volume for 10 seconds.
  • 3
  • 0
Matt Dermody | posted this 22 June 2021

This is awesome, thanks Shawn. 

  • 0
  • 0
Joe | posted this 22 June 2021

This works perfectly. Having the variables is great for different instances too. Thanks!

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback