Problem enrolling Samsung Devices to SOTI

Problem enrolling Samsung Devices to SOTI

Hello,

 

We are trying to enroll Samsung Galaxy Xcover -devices to SOTI, but have run into problems. I'll try to explain all of our situations as well as possible, but apologies if I forget something.

Anyway, the devices run on Android 11, while out SOTI client is running version 15.2. SHA-2 is enabled.

First, I have tried enrolling with Android classic Mobicontrol. I found one from SOTI site, that should work. Non-ELM was seemingly not supported anymore, so I tried with ELM enabled device. There is a small problem with it, because our production network for SOTI clients do not have access to public network. In order for me complete the enrolling, I have to switch WLAN networks to a more public one during it. I was able to do this once, but subsequent enrolls fail upon completion and unenroll themselves. After that I have to do enterprise data reset in order to try enrolling again.

I decided to try using the more universal Google Mobicontrol afterwards. The enrollment succeeds, but the devices do not support remote control and always install a work profile. I got some guidance from our seller, that I should enroll the device during the initial bootup, by using the camera to read a QR-code from Mobicontrol stage program. That worked on a Zebra device we have, but on Samsung device I ran into different problems. Because our production environment do not have access to Google play, I must do the initial installation on a different network, so the device gan download the Mobicontrol app. After that, the device starts to enroll, but for some reason I am unable to change settings during the installation. On Zebra device I am able to open Android during enrolling (Zebra runs on Android 8), but on Samsung I can't back out to Android during enrollment, meaning I am unable to change to production network. Is this because of a different Android version?

 

If anyone can give me some hints about how should I proceed with enrollment, I would be very thankful.

4 Answers

Order By:   Standard | Newest | Votes
Rafael Schäfer | posted this 07 September 2021

1. Tipp: Maybe use a zero-touch QR-Code with all relevant information in it (Wifi Settings too but without proxy settings!).

2. Tipp: You can create a Mobicontrol Stage barcode for the mobicontrol app with wifi settings in (proxy settings only without bypass!)

  • 0
  • 0
Ozan Acikalin | posted this 07 September 2021

The remote control on your second attempt enrolling the devices failed because you configured the devices as
Managed Work Profile. That supports only remote view. You have to enroll them as fully work managed device.

There are few ways to archive that:

First you have to factory reset the device. That is neccessary to get a device enrolled as a fully work managed device.


On the welcome screen (where you can set the language) you can draw a + sign (plus sign). When you use Samsung Knox
services like Knox Mobile Enrollment you can scan a QR-Code to start the enrollment.
(Knox Mobile Enrollment is a zero touch enrollment service by Samsung)

The other option is to tap 6 times in a corner on the welcome screen. Then you can scan the QR-Code you created
by using the Stage Program or Zero Touch by Google.

The last option i know is the manually way. You set up the device until you reach the step where you can sign
in with your google account. In the field for the email adress you enter afw#mobicontrol and press sign in.
That will start the process to enroll the device as fully managed devices into MobiControl. Just follow the steps on
the screen. it will download and install the enterprise agent for the device. Later it will start the mobicontrol agent
and force you to enter a enrollment ID.

  • 0
  • 0
Antti Nikkilä | posted this 14 September 2021

The last option worked for me. When using that, I was able to switch WLAN's during enrolling and get the device to SOTI. However, the device still does not support remote control, which is needed in our environment. There is an option for remote view, but control is not available.

I remember reading somewhere that Andoid 11 needs some kind of extra plugin installed to the device in order for remote control to work, is this true? We have other devices with Android 8, those devices support remote control right out of the box, when enrolled with QR code.

  • 0
  • 0
Rafael Schäfer | posted this 14 September 2021

Normally the plugins will be installed automatically. Even there's a command "Install Device-Plugin" which you can look for if this is possible or not.

If there's no plugin (even available in your Soti; i don't know which version you are using) you can download it here: https://docs.soti.net/mobicontrolagentdownloads/ and deploy it via profile to the devices.

But if there's still a plugin on the device try following:

send script to the device:

_resetfailedrcdetectionflag
restartagent
 
This should help or try a reboot if not done until now.
  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback