Problem with Symbol WT41N0

Problem with Symbol WT41N0

Hello,

 

I have a problem with Symbol WT41N0. (Windows Mobile/CE) Device is enrolled in SOTI Mobicontrol 14.4.3.1153.

After cold restart with 1, 9 and power button device loose time settings and reset them to 2012. 

In this case there is no connection to soti server. Connection can be done if we  set time to corect date and year.

How we can avoid this?

We have set up remote time synchronization thru SOTI agent from SOTI Server/ Time server  but result was the same.

How we can save correct time after restart to be sure that device can connect to SOTI server?

Best: Milen

 

2 Answers

Order By:   Standard | Newest | Votes
María José | posted this 29 October 2019

Hello,

 

I had a lot of problems with those devices. 

I solved this problem with a .reg. You must modify the NTP servers:

-------------------------------------

[HKEY_LOCAL_MACHINE\Services\TIMESVC]
; default OS will go to public NTP change to your internal NTP if needed.
"server"=multi_sz:"pool.ntp.org","tock.usno.navy.mil","time.windows.com"
;"server"=multi_sz:"myinternalNTP.com"


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\clock]
"AutoDST"=dword:00000001

[HKEY_LOCAL_MACHINE\Time Zones]
@="Eastern Standard Time"
"DefaultTZID"=dword:00000023


;MC92 MC32 WT41 equals W. Europe Standard Time
[HKEY_LOCAL_MACHINE\Time]
"TZID"=dword:0000053C

[HKEY_LOCAL_MACHINE\Time]
"TimeZoneInformation"=hex:\
C4,FF,FF,FF,57,00,2E,00,20,00,45,00,75,00,72,00,6F,00,70,00,65,00,20,00,\
53,00,74,00,61,00,6E,00,64,00,61,00,72,00,64,00,20,00,54,00,69,00,6D,00,\
65,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,0A,00,\
00,00,05,00,03,00,00,00,00,00,00,00,00,00,00,00,57,00,2E,00,20,00,45,00,\
75,00,72,00,6F,00,70,00,65,00,20,00,44,00,61,00,79,00,6C,00,69,00,67,00,\
68,00,74,00,20,00,54,00,69,00,6D,00,65,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,03,00,00,00,05,00,02,00,00,00,00,00,00,00,\
C4,FF,FF,FF


;MC32 has however RTC backup implemented ( MC92 / WT41 / VC70 donâ??t )
;So if you need NTP then disable RTC backup with following regkey
;[HKEY_LOCAL_MACHINE\Software\Motorola\BackupRtc]
;"Disable"=dword:00000001

 

----------------------------------------------

 

Hope help you.

 

 

  • 0
  • 0
Matt Dermody | posted this 29 October 2019

If you place the .reg file in the /application folder on the device it will be automatically merged on a coldboot. 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback