Remove Chrome URL bar

Remove Chrome URL bar

I found this topic: https://discussions.soti.net/thread/chrome-lockdown-disable-url-bar/ and it seems to work for them.
The script perhaps needs some edit or something, or i'm doing something wrong...not sure.

Either way it did not work too well for me, then again Javascript is not a language I know too well.
I generally stick to HTML / CSS.

The way I have it right now is:

<html>

<head>

<style type="text/css">

</style>

<script>

function openUrl()

{

var options = "location=no, toolbar=no, menubar=no, scrollbars=yes, resizable=yes";

var theUrl = "<MCLink0>";

// TEST URL alert(theUrl);

window.open(theUrl, "", options);

}

</script>

</head>

<body>

<div id="Main">
<div class="row">
<ul>
<td onclick="openUrl();">
<li><A href ="<MCLink0>"><img src="<MCExeIcon0>" onerror="this.style.display='none'" /><div class="txt"><MCDISP0></div></a></li>
<li><A href ="<MCLink1>"><img src="<MCExeIcon1>" onerror="this.style.display='none'" /><div class="txt"><MCDISP1></div></a></li>
</td>
</ul>
</div>

</body>

</html>

 

Ofcourse I have more CSS and etc in between, but this is just the layout I have put it in.
Since the topic I mentioned is locked, does anyone else have experience with this?

8 Answers

Order By:   Standard | Newest | Votes
Bhav | posted this 15 June 2021

I had fun with this a while back, Surf was our saviour. Have you considered using surf instead of chrome?

 

https://discussions.soti.net/thread/open-chrome-without-address-bar-1/

  • 0
  • 0
Wesley | posted this 15 June 2021

Hi Bhav,

I definitely have tried Surf, however it does not allow any URL you want...

Yet this is currently the only method to browse there.

It sucks that Chrome has shortcuts but this being the only method to use the fullscreen mode.
And that there is no way to apply this shortcut into lockdown.

  • 0
  • 0
Raymond Chan | posted this 15 June 2021

Are you using MobiControl Lockdown-Menu/Kiosk on your device to access either Chrome or Soti Surf?

If so, how did you specify your kiosk item to access https://icts.wacs.online/ICTSPlatform? 

Did you try to specify "https://icts.wacs.online/ICTSPlatform" in Soti Surf profile configuration payload?  What are the version and build numbers of the Soti Surf secure-browser app you are trying?

 

  • 0
  • 0
Wesley | posted this 15 June 2021

Hello Raymond,

I have both Chrome and Surf in kiosk to test both.

I tested chrome with: Intent://(URL)#Intent;scheme=http;action=android.intent.action.VIEW;component=com.android.chrome;end

Surf I have as an application with: Launch://net.soti.surf.
In Profiles -> Soti Apps -> Soti Surf I tried to add the url required, but I get the message mentioned above.
Most likely because it has no .com or something similar in the url, so it doesn't understand.

Soti surf version is: 15.3.2 Build 3 (downloaded from play-store)
Mobicontrol version is: 15.0.1.1181

 

  • 0
  • 0
ANKMOD@SOTI | posted this 15 June 2021

Hello Wesley

Greetings

Thanks for your Post on Soti central!!

Kindly confirm if you have tested by  launching your url directly on lockdown  as mentioned below without launching soti surf on lockdown  and see if you are able to see the url or not.

 

Secondly On Soti surf , irrespective of your soti surf version, You must be able to use url as shown below and it has been tested on different MobiControl version as mentioned below. Can you confirm if  you are applying URL in soti surf as shown below?

Regards

Technical Support | SOTI Inc. |+1-888-494-SOTI (7684) | support@soti.net | www.soti.net |

  • 0
  • 0
Matt Dermody | posted this 15 June 2021

It looks like Wesley is working with a newer version of MobiControl that may in fact have some sort of URL check built in. 

 

If the Surf configuration Profile won't let you put in that URL format what about the surf:// option in the lockdown?

 

  • 0
  • 0
Bhav | posted this 15 June 2021

Running mulitple versions and agree there is a check on the URL, but I don't get the "not well-formed" message when I enter...

for shits and giggles:

  • 0
  • 0
Wesley | posted this 16 June 2021

I can say that the Surf:// method does work with the url just fine.
It does however just like Chrome keep opening it in a new tab, thats kind of a bummer.

And I tried the url as you mentioned but I get the error message, this feels like it needs a fix because if it works with surf:// it should also work in its own profile menu.

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback