Samsung Tab A Remote Control Failure

Samsung Tab A Remote Control Failure

Hello,

I have enrolled an Samsung Tab A 2019 as an Android Enterprise Device in Soti.

The Tablet has Android 10. When I try to remoteControl the Device, where I have to push the "Start Now" Button, where It asks to start the Stream.

After that the Tablet disconnects from Soti and I can't controll it via remote.

Is there a solution?
Tanks for your support!

12 Answers

Order By:   Standard | Newest | Votes
Raymond Chan | posted this 13 January 2021

What are the active MDM api's reported in the configuration tab of your device agent or in the information tab of the device in the web-console?

 

What about the version and build numbers of your device agent?

 

  • 0
  • 0
Jln145 | posted this 13 January 2021

Agentversion: 14.4.2 Build 1039

MDM API: Work Managed Device, Remote View 1.18.1.100

  • 0
  • 0
JSMOD@SOTI | posted this 15 January 2021

Hello,

 

Thank you for posting on SOTI Central.

 

It seems there is a similar issue which should be fixed with the new Android Enterprise v14.4.3 agent. Could you please upgrade the agent on a test device and share the results?

 

Kind regards,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Raymond Chan | posted this 15 January 2021

What agent did you test with?  Make sure the Active MDM API list reported include an entry  "RC ##" rather than "Remote View ##.##".

 

  • 0
  • 0
Jln145 | posted this 20 January 2021

Tanks for your answers and sorry for the late response.

After updating the Agent I don't get the error anymore, but I'm still not able to remotecontrol the device. I can View only.

The Agent is teh standard Android Enterprise I think.
I enrolled the device in Android Enterprise with afw#mobicontrol

 

  • 0
  • 0
JSMOD@SOTI | posted this 21 January 2021

Hello,

 

The device might not have activated correctly - a couple suggestions for this:

 

  • Try below scripts to the device to retry RC detection:
    •    retryrcdetection
    •    _resetfailedrcdetectionflag

         restartagent
  • Check the "ELM Status" of the device on the Web Console. If this is not showing as 'Active' you can send the below script to the device which will prompt the user to accept the User Agreement
    •    reset_elm_license
         restartagent
  • Factory reset the device and setup from fresh with the afw#mobicontrol method. If the above scripts didn't work then this should reset the RC status

 

Kind regards,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Jln145 | posted this 25 January 2021

Hello, the scripts and also the factory reset doesn't help.

The ELM Status is "activation failed"

  • 0
  • 0
Raymond Chan | posted this 25 January 2021

Have you tried testing with any agent version(s) other than  v14.4.2 Build 1039?  You can use the freely downloadable Soti Stage Programmer Utility app from Google Play store, together with proper configuration file,  to choose enrolling your AE device with a specific device agent of your choice. 

 

If the problem persists for various device agent versions, then there is a higher possibility that the problem stems from your Tab A device firmware, or from your MobiControl server if there is similar remote-control problem with AE devices of other OEM brand(s)/model(s) on this same server.

 

About 2 years ago, one of my customer had very similar remote-control problem on a particular Samsung tablet model.  After Soti and Samsung had confirmed based on our test results that the problem stemmed from Samsung device firmware, my customer had to wait for Samsung to release firmware patches.  Those devices bought and shipped to Hong Kong received firmware patch and had the problem fixed within about 1 month, while those of the same model name but shipped to mainland China actually had a different part number and firmware managed by a different Samsung software team.  Eventually, it took another 2 extra months for the corresponding patch to be released for those devices.  

  • 0
  • 0
JSMOD@SOTI | posted this 25 January 2021

Hi,

 

Did you receive a prompt on the device to accept the ELM User Agreement when sending the "reset_elm_license" script?

 

Please ensure that the device can reach the necessary domains for ELM activation in your region: https://docs.samsungknox.com/admin/knox-platform-for-enterprise/faqs/faq-115013575167.htm

 

Kind regards,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Jln145 | posted this 26 January 2021

Thank you for the answers!

The error occurs only on thias Samsung Device. Withe Zebra or Huawei aren't any problems.

This Tab A is the only Samsung device. I will put the device on the whitelist of our firewall and let you know if it works.

 

Kind regards

  • 1
  • 0
JSMOD@SOTI | posted this 09 February 2021

Hi there,

 

Following up on this thread, were you able to resolve the issue? If so, kindly share the fix and/or mark the appropriate comment as 'Solution' to help others find the answer.

 

Many thanks,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Jln145 | posted this 22 February 2021

That's the Solution, thanks a lot!

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback