Samsung XCover 4S devices not enrolling

Samsung XCover 4S devices not enrolling

Hi

I've had a report that new XCover 4s's are failing to enroll.

The evidence I have so far (I get a device in a day or so to verify) is that they are following standard procedure for a new build by entering afw#mobicontrol at the verification screen.  When they get to the enrolment screen they enter the key, press enrol and it fails.

There is nothing in the logs to show an attempt has been made.  They have tried multiple WiFi connections (although how could they download if not) and no working SIM is installed yet.

I have tried a 4S I have in the office and that enrols fine.  Other devices (Samsung XCover 4) have enrolled in the last few days.

server is 14.4.9

Does anyone have any suggestions of things to try?

4 Answers

Order By:   Standard | Newest | Votes
Eddie | posted this 13 August 2020

This was indeed the case.  The test device we were sent was 9 but the batch they received was 10.  

a 3 hour call with EU support got us a temporary solution of a wildcard certificate to get us up and running whilst the SHA2 propagates across our estate over the next few weeks.

  • 0
  • 0
Paul | posted this 13 August 2020

Maybe the new xcovers have Android 10. Then you need a SHA-256 SSL certificate on the mobicontrol server.

  • 0
  • 0
DDMOD@SOTI | posted this 06 August 2020

Hi Eddie,

 

Thanks for posting your concern!

Can you please confirm if this is the first time you are encountering such issue?

Is your On-premise server is restricted to external connections? 

What error message is displayed on the device when you enter the enrollment ID?

If the Device Management address has the Internal IP address of your server, then the device enrollment fails.

 

Please confirm.

Regards,

Technical Support | SOTI Inc. |+1-888-494-SOTI (7684) | support@soti.net | www.soti.net |

  • 0
  • 0
Ben Smith | posted this 03 August 2020

I'm showing this as well for a lot of my Android Enterprise devices, I have three Zebra MC33 devices doing the exact same thing. I also had the same thing for two Samsung Tab A devices, but eventually, they were able to be enrolled, but it provided a certificate error and I had to "trust" in order to proceed.

I have a ticket open, but no solution yet.

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback