Serial number macro in the device setup is not showing for Zebra TC26 device

Serial number macro in the device setup is not showing for Zebra TC26 device

Hi,

I have two devices (MC93 and TC26), in my rule for adding device, I have set it to

%MODEL%-%MAC%-%SERIALNUM%

But I faced an issue with the TC26 where it is not showing the serial number in the device name (MC93 is working fine).

MC93-78b8d60765ad-20093522506180
TC26-78b8d633586a-
But hardware serial number is available in TC26 once I checked in the device details.

Kindly see the details below of the device:

MC93-Android 8.1.0-Agent 14.4.6.1001

TC26-Android 10-Agent 14.4.6.1001

MobiControl Version: 15.2.4.1138

Please advise.

Thank you,

Vincent

4 Answers

Order By:   Standard | Newest | Votes
ANKMOD@SOTI | posted this 16 March 2021

Hello Vincent

Greetings for the day!!

Thanks for your Post on Soti Central!!

Since the issue  is happening on one particular model of same manufacturing zebra device inspite of having serial no mentioned in device details as you mentioned so kindly test the following and let us know the outcome

1. Is this issue happening on a single or multiple TC26 devices 

2. Are you able to test by renaming the device using below macros and what was the output for TC26.

%MODEL%-%MAC%-%SERIALNUM% and also by using only %SERIALNUM%
 
3.Since there is one particular model is having this issue , can you try to re-enroll this device and let us know if the issue is reproducable by using the same macro %MODEL%-%MAC%-%SERIALNUM%
4.There may be a possibility that some brands and model does not return anything while usign macro but will give you an update on that.
 
In case of any other issue , please feel free to ask.
 
Regards!!
 

 

Technical Support | SOTI Inc. |+1-888-494-SOTI (7684) | support@soti.net | www.soti.net |

  • 1
  • 0
Vincent | posted this 17 March 2021

Hi,

Kindly see the update for each points below:

1. This is also happening to multiple TC26 devices.

2. The device is showing with AndroidPlus 00001.

3. Tried multiple times re-enrolling the device (with and without enterprise reset) but with no avail.

4. Please update us once it is cleared from your side.

 

Regards!

  • 0
  • 0
Raymond Chan | posted this 17 March 2021

Have you try setting test script command such as

 

    showmessagebox "Ser Num: %SERIALNUM%" 

 

 to an ENROLLED TC26 and see if anything meaningful is displayed.   Your problem may be due to outdate firmware not compatible with new restrictions imposed on Android 10+ Android-Enterrprise devices.  If so, your problem might be solved after installing new Zebra firmware patch, hopefully to be released in the near future if Zebra knows about the problem.  If the test above gives correct serial number, then there might be some work to be done on Soti side to fix the problem.

 

  • 1
  • 0
Vincent | posted this 17 March 2021

Hi,

The test script above is working fine.

Also I observed that the device serial number is not available once I enrolled the device. But after doing the necessary work profile permission in the phone, the serial number is now displaying in the device details.

My guess is the device is not allowing SOTI to check the hardware serial number and will only be available after allowing some necessary phone permission.

Thank you again for replying to my question.

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback