Settings Manager Bug on Android

Settings Manager Bug on Android

This afternoon I loaded the latest Settings Manager (15.0.0 build 14) as it now supports Android 10 and 11. However, when I attempt to do anything in the app it tells me that I need MobiControl agent 14.4.7 or higher to use this feature.

Okay, sure. I check my version of the agent and I'm at 14.5.0 build 1011 so I should be okay.

Ideas? Anyone else seeing this?

2 Answers

Order By:   Standard | Newest | Votes
JSMOD@SOTI | posted this 07 May 2021

Hi Ryan,

 

Thank you for posting on SOTI Central.

 

I have come across something similar to this recently, although it has been inconsistent when reproducing the issue between different devices. Have you tried fully killing the Settings Manager app and also performing a soft reset of the device to see if this helps?

 

Currently, there is a 'workaround' which involves wiping the Enterprise device, re-enrolling and re-installing Settings Manager. However, I of course understand this is not suitable long-term especially if you have many devices, so I encourage you to please open a case with SOTI Support (email support@soti.net) so we can gather necessary logs and raise a development ticket.

 

Many thanks,

 

Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net | www.soti.net |

  • 0
  • 0
Ryan Grimm | posted this 07 May 2021

Yeah, before my original post I FC'd Settings Manager and wiped the data cache for good measure and performed a reboot without success. I even cleared the MobiControl Agent app cache too, just because.

We'll open a ticket. Wiping a few thousand devices is not an option.

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback