Soti Surf with Camera Permissions

Soti Surf with Camera Permissions

Hello all,

 I am working on a tablet configuration that will access a website that is being developed by a company that we have hired. The website requires the camera in order to scan barcodes. I have a configuration set up on a Lenovo P10 device which includes AFW and a lockdown Kiosk Mode. We tried to use Chrome as our web browser but we don't want the end users to be able to access the address bar or anything else involved in the top menu. The website works in Chrome though. That is when we decided to use SOTI Surf instead. Now when we navigate to the URL, it says "Camera (no Permissions (X))" but the picture comes up. After about a day of downtime, I will try to access the same website with no picture in the picturebox. It's as if Surf has realized that it shouldn't be allowed and then blocks it. It only starts blocking it after a certain amount of time. (usually overnight). Any suggestions?

5 Answers

Order By:   Standard | Newest | Votes
GPMOD@SOTI | posted this 15 April 2019

Hello Patrick,

I understand that you are using the kiosk mode for the device. If I may ask, have you allowed permissions for the device to use the camera application within the lockdown, by entering the camera bundle-id in the kiosk mode?

Thank you.

SOTI Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net

  • 0
  • 0
Patrick Cromie | posted this 15 April 2019

I am not sure where I would put the bundle-id in the Kiosk Mode to allow it. The only place I can see that would allow it would be under the "Application Run Control" and I only have the ability to blacklist things.

  • 0
  • 0
GPMOD@SOTI | posted this 15 April 2019

It is like adding any other app in the kiosk mode. Enter the bundle-id in the kiosk mode configurations. Since you want to use the functionality of the camera in another app, and I believe you don't want the users to see the camera app in itself, in the kiosk mode. You can hide the same by editing the HTML template.

Thank you,

SOTI Technical Support | SOTI Inc. | 1.905.624.9828 | support@soti.net

  • 0
  • 0
Patrick Cromie | posted this 15 April 2019

Unfortunately, I have done what you have asked and it still says that the camera has no permission.

The camera has popped up but it still says no permission. The other down side is that it usually takes a while to "Fail" so I will let it go over night and check back in with an update tomorrow.

  • 0
  • 0
Raymond Chan | posted this 16 April 2019

The website you access probably include  html5/javascript codes that need camera permission.  You likely need to make an official feature request to Soti for addition of camera permission  (as well as "enable/disable camera" privacy option in Soti Surf configuration payload) in Soti Surf secure browser apk.

 

  • 0
  • 0

Give us your feedback
Give us your feedback
Feedback